Bug 255752 - net/ldapbrowser: fix compilation after regression in previous change
Summary: net/ldapbrowser: fix compilation after regression in previous change
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dima Panov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-10 16:01 UTC by Ronald Klop
Modified: 2021-05-20 10:37 UTC (History)
2 users (show)

See Also:


Attachments
fix the license name to not conflict with the directory name (500 bytes, patch)
2021-05-10 16:01 UTC, Ronald Klop
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald Klop 2021-05-10 16:01:15 UTC
Created attachment 224812 [details]
fix the license name to not conflict with the directory name

This change broke the port:
ports r3505159e72da2d
review D30010

===>  Extracting for ldapbrowser-2.8.2_4
=> SHA256 Checksum OK for Browser282b2.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
/bin/sh: cannot create /wrkdirs/usr/ports/net/ldapbrowser/work/ldapbrowser: Is a directory
*** Error code 2

Stop.
make: stopped in /usr/ports/net/ldapbrowser



If the license has the same identifier as the name of the directory it can't write to it.
Comment 1 Dima Panov freebsd_committer 2021-05-20 09:09:34 UTC
Looks like it fixed by: https://cgit.FreeBSD.org/ports/commit/?id=a0c694d15d97dfefdda209823d47440fbfa02d3a
Comment 2 Ronald Klop 2021-05-20 10:37:41 UTC
Oh, it is fixed in the meantime.

Communication with maintainers of ports is no holy thing apparently,

https://cgit.freebsd.org/ports/commit/?id=a0c694d15d97dfefdda209823d47440fbfa02d3a

But thanks for the fix.