Bug 255783 - www/typo3-10: Update to 10.4.16
Summary: www/typo3-10: Update to 10.4.16
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Nuno Teixeira
URL:
Keywords:
: 254370 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-11 10:33 UTC by Helmut Ritter
Modified: 2021-05-26 10:00 UTC (History)
1 user (show)

See Also:


Attachments
Update to 10.4.16 (861 bytes, text/plain)
2021-05-11 10:33 UTC, Helmut Ritter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Ritter 2021-05-11 10:33:20 UTC
Created attachment 224836 [details]
Update to 10.4.16

These versions are maintenance releases and contain bug fixes only.

For details about the releases, please see:

https://get.typo3.org/release-notes/10.4.16
https://get.typo3.org/release-notes/9.5.27

or our news https://typo3.org/article/typo3-10416-and-9527-maintenance-releases-published
Comment 1 Nuno Teixeira freebsd_committer 2021-05-12 06:20:20 UTC
Hello,

I coudn't aply your patch with 'git apply'. How did you generated this patch?

This diff is very small so I will apply it manualy.

Plea always send patches with 'git diff'.

Thanks
Comment 2 Helmut Ritter 2021-05-12 08:20:42 UTC
I'm currently using "port diff" from porttools.
Comment 3 Nuno Teixeira freebsd_committer 2021-05-12 08:36:59 UTC
(In reply to Helmut Ritter from comment #2)
Ok, I will try to find a way to apply those patches too.

Porter's Handbook recommends 'git diff':
https://docs.freebsd.org/en/books/porters-handbook/upgrading/#git-diff
Comment 4 Nuno Teixeira freebsd_committer 2021-05-12 08:58:11 UTC
Hello,

Could you try 'poudriere testport -o www/typo3-10'?

I'm getting a pkg-plist error:
---
====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: @dir %%WWWDIR%%_src-10.4.16/vendor/symfony/string/Resources/bin
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

Stop.
make: stopped in /usr/ports/www/typo3-10
=>> Error: check-plist failures detected
build of www/typo3-10 | typo3-10-php74-10.4.16 ended at Wed May 12 09:56:01 WEST 2021
build time: 00:00:29
!!! build failure encountered !!!
[00:00:49] Error: Build failed in phase: check-plist
---

Any hints?
Comment 5 Helmut Ritter 2021-05-12 10:14:17 UTC
(In reply to Nuno Teixeira from comment #4)

I don't have poudriere but see also https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255090. The directory exists but is empty and I don't know how to fix that.
Comment 6 Nuno Teixeira freebsd_committer 2021-05-12 10:24:53 UTC
*** Bug 255090 has been marked as a duplicate of this bug. ***
Comment 8 Nuno Teixeira freebsd_committer 2021-05-12 10:48:18 UTC
(In reply to Helmut Ritter from comment #5)
Please use Poudriere! It's a really nice tool where you can test ports in clean environment :)
Comment 9 Helmut Ritter 2021-05-12 13:14:10 UTC
(In reply to Nuno Teixeira from comment #8)

I only have 1 small VM running FreeBSD at home. :)

I did something like this in the past but then at some time was told it is not required anymore:

https://www.charlieroot.de/FreeBSD/PRs/build_www_typo3-10_2021-05-11-12-29.log
Comment 10 Nuno Teixeira freebsd_committer 2021-05-13 06:13:36 UTC
Hello!

Ports framework don't like to install empty directories.

I will use @RMDIR to delete that empty directory. I will have to test

'@{RMDIR} /vendor/symfony/string/Resources/bin' this weekend.
Comment 11 Nuno Teixeira freebsd_committer 2021-05-14 06:49:33 UTC
*** Bug 254370 has been marked as a duplicate of this bug. ***
Comment 12 commit-hook freebsd_committer 2021-05-26 09:49:15 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=d16aec0ea088b35ab0db76e5652b6f6e6e71ce5a

commit d16aec0ea088b35ab0db76e5652b6f6e6e71ce5a
Author:     Nuno Teixeira <eduardo@FreeBSD.org>
AuthorDate: 2021-05-26 09:37:43 +0000
Commit:     Nuno Teixeira <eduardo@FreeBSD.org>
CommitDate: 2021-05-26 09:37:43 +0000

    www/typo3-10: Update to 10.4.16

    - Use a small workarourd fix for:
    ---
    ===> Checking for items in STAGEDIR missing from pkg-plist
    Error: Orphaned: @dir %%WWWDIR%%_src-10.4.16/vendor/symfony/string/Resources/bin
    ===> Checking for items in pkg-plist which are not in STAGEDIR
    ---
    with
    ---
    do-install: ${RMDIR} ${WRKSRC}/vendor/symfony/string/Resources/bin
    ---
    to delete that empty directory.

    ChangeLog: https://get.typo3.org/release-notes/10.4.16

    PR:             255783
    Approved by:    dbaio, garga (mentors, implicit)

 www/typo3-10/Makefile | 7 ++++++-
 www/typo3-10/distinfo | 6 +++---
 2 files changed, 9 insertions(+), 4 deletions(-)
Comment 13 Nuno Teixeira freebsd_committer 2021-05-26 10:00:11 UTC
Commited thanks!