Bug 255787 - x11-toolkits/qt5-gui: make X11=off not turn off graphics completely
Summary: x11-toolkits/qt5-gui: make X11=off not turn off graphics completely
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords: patch
Depends on: 254584
Blocks:
  Show dependency treegraph
 
Reported: 2021-05-11 13:30 UTC by Evgeniy Khramtsov
Modified: 2021-06-28 09:36 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments
patch (45.45 KB, patch)
2021-05-11 13:30 UTC, Evgeniy Khramtsov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Evgeniy Khramtsov 2021-05-11 13:30:00 UTC
Created attachment 224844 [details]
patch

This patch is [1/4] from series of patches. The patches are posted in the order poudriere builds qt5-gui and its dependencies.

This is needed for qt5-gui to build and run in a pure Wayland environment. Tested with:

DEFAULT_VERSIONS+= gl=mesa-devel
OPTIONS_SET+=   GLESV2
OPTIONS_UNSET+= CONSOLEKIT OPENGL PULSEAUDIO VDPAU X11 XCB XLIB

Note that Qt 5 has a weird build system that picks up if libX11 is installed or not. Turning off X11 like adding no-xcb and stuff to QT_CONFIG does not work. I currently don't have the time to dig deeper into Qt build system, I already have PipeWire to do. This depends on bug 254584, because xkeyboard-config gets installed into poudriere jail, without that patch libX11 gets installed.

Tested both pure Wayland and X11 with KeepassXC and this series of patches. Note that KeePassXC includes Xlib in one place, I locally patched it for pure Wayland.

This should build a Qt application in a pure Wayland environment that depends on qt5-gui and does not include X11 dependencies.

I know that there are other Qt 5 ports as well, though one can't start making X11 optional without the qt5-gui port first.

PORTREVISION is bumped to catch regressions if any.
Comment 1 Evgeniy Khramtsov 2021-06-27 14:25:37 UTC
I can't improve this patch (find out how to force disable automagic dependency) due to burnout and lack of spare time caused by unrelated events. Maintained version of this may live for some time in https://codeberg.org/ei/ports/commits/branch/ei, though that branch may also become unmaintained and/or deleted. Closing this and "see also" PRs. While here, sorry for the mailing list noise it can create. I didn't know that FreeBSD bugzilla defaults are *that* noisy.
Comment 2 Adriaan de Groot freebsd_committer 2021-06-28 09:36:12 UTC
I have preserved the four patches in branch `qt5-optional-x11` in kde@'s "Area51" repository (https://community.kde.org/FreeBSD/Setup/Area51) which we use to stage things for testing. Thank you for sending them in, and I wish you well.

I think this patch seies could have used a "yeah, that's cool" kind of response (from us) at the least. It's not necessarily lack of interest, but lack of time: just *trying* these patches takes a fair bit of effort.