Bug 255806 - devel/py-oci: update to 2.38.2
Summary: devel/py-oci: update to 2.38.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rainer Hurling
URL: https://github.com/oracle/oci-python-...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-12 06:01 UTC by Alessandro Sagratini
Modified: 2021-05-12 08:33 UTC (History)
2 users (show)

See Also:


Attachments
trivial update of Makefile and distinfo (927 bytes, patch)
2021-05-12 06:01 UTC, Alessandro Sagratini
ale_sagra: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Sagratini 2021-05-12 06:01:11 UTC
Created attachment 224863 [details]
trivial update of Makefile and distinfo

trivial update of Makefile and distinfo
Comment 1 commit-hook freebsd_committer 2021-05-12 08:03:44 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=786eaee2898590a74d8b46d247ecbdfa1b3a2a10

commit 786eaee2898590a74d8b46d247ecbdfa1b3a2a10
Author:     Rainer Hurling <rhurlin@FreeBSD.org>
AuthorDate: 2021-05-12 08:00:28 +0000
Commit:     Rainer Hurling <rhurlin@FreeBSD.org>
CommitDate: 2021-05-12 08:00:28 +0000

    devel/py-oci: Update to 2.38.2

    Changelog: https://github.com/oracle/oci-python-sdk/releases/tag/v2.38.2

    PR:             255806
    Reported by:    Alessandro Sagratini <ale_sagra@hotmail.com> (maintainer)

 devel/py-oci/Makefile | 2 +-
 devel/py-oci/distinfo | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)
Comment 2 Rainer Hurling freebsd_committer 2021-05-12 08:16:42 UTC
Hi Alessandro,

As you know, if the port is build on a 11.x system, which uses (outdated) openssl from base, this system also has to use security/py-cryptography v2.9.2[1], which results in a build failure of your port:

[F114i386-default-qgis-job-01] Extracting py37-cryptography-2.9.2: .......... done
===>   py37-oci-2.38.2 depends on package: py37-cryptography>=3.2.1 - not found
*** Error code 1
Stop.
make: stopped in /usr/ports/devel/py-oci


Since this does not give the user a direct indication of the underlying problem for the termination, wouldn't it be nice to have a note of this in future releases? (for the remaining time of FreeBSD 11.x)


[1] Extract from security/py-cryptography/Makefile:l46-55:
# We need to keep old py-cryptography and py-openssl for 11.x release
# due to outdated OpenSSL version in base
.if ${OPSYS} == FreeBSD && ${SSL_DEFAULT} == "base"
. if ${OSVERSION} >= 1103500 && ${OSVERSION} < 1200085
# 1103500	352193 2019-09-10	11.3-STABLE got OpenSSL 1.0.2t
# 1200085	339270 2018-10-19	12.0-STABLE got OpenSSL 1.1.1
PORTVERSION=	2.9.2
EXTRA_PATCHES=	${PATCHDIR}/openssl102u
. endif
.endif


Committed v2.38.2, thanks!
Comment 3 Rainer Hurling freebsd_committer 2021-05-12 08:33:39 UTC
(In reply to Rainer Hurling from comment #2)

A small afterthought:
The mentioned note for the user could also contain a hint that the user can build the port by setting the entry DEFAULT_VERSIONS+= ssl=openssl in /etc/make.conf to use the OpenSSL version from the ports ;)