Bug 255954 - mail/thunderbird: Fix compile error with clang/libc++ 12
Summary: mail/thunderbird: Fix compile error with clang/libc++ 12
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Christoph Moench-Tegeder
URL:
Keywords: needs-qa
Depends on:
Blocks: 255570
  Show dependency treegraph
 
Reported: 2021-05-17 19:09 UTC by Dimitry Andric
Modified: 2021-05-18 08:42 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gecko)
koobs: merge-quarterly?


Attachments
Apply upstream fix for building against libc++ 12 (1.50 KB, patch)
2021-05-17 19:09 UTC, Dimitry Andric
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2021-05-17 19:09:15 UTC
Created attachment 225037 [details]
Apply upstream fix for building against libc++ 12

During an exp-run for llvm 12 (see bug 255570), it turned out that mail/thunderbird does not build with clang 12.0.0 [1]:

In file included from /wrkdirs/usr/ports/mail/thunderbird/work/thunderbird-78.10.0/media/webrtc/trunk/webrtc/modules/audio_processing/beamformer/covariance_matrix_generator.cc:13:
In file included from /wrkdirs/usr/ports/mail/thunderbird/work/thunderbird-78.10.0/media/webrtc/trunk/webrtc/modules/audio_processing/beamformer/covariance_matrix_generator.h:14:
In file included from /wrkdirs/usr/ports/mail/thunderbird/work/thunderbird-78.10.0/media/webrtc/trunk/webrtc/modules/audio_processing/beamformer/complex_matrix.h:14:
In file included from /wrkdirs/usr/ports/mail/thunderbird/work/.build/dist/system_wrappers/complex:3:
In file included from /usr/include/c++/v1/complex:236:
In file included from /usr/include/c++/v1/stdexcept:46:
In file included from /wrkdirs/usr/ports/mail/thunderbird/work/.build/dist/system_wrappers/exception:3:
In file included from /usr/include/c++/v1/exception:81:
In file included from /usr/include/c++/v1/__memory/base.h:14:
In file included from /usr/include/c++/v1/__debug:14:
In file included from /wrkdirs/usr/ports/mail/thunderbird/work/.build/dist/stl_wrappers/iosfwd:58:
In file included from /wrkdirs/usr/ports/mail/thunderbird/work/.build/dist/include/mozilla/mozalloc.h:31:
In file included from /wrkdirs/usr/ports/mail/thunderbird/work/.build/dist/stl_wrappers/new:52:
In file included from /wrkdirs/usr/ports/mail/thunderbird/work/.build/dist/system_wrappers/new:3:
/usr/include/c++/v1/new:127:14: error: expected class name
    : public exception
             ^
1 error generated.

This is caused by thunderbird doing a lot of complex and fragile juggling with system headers, and was reported upstream as <https://bugzilla.mozilla.org/show_bug.cgi?id=1694575>, then fixed via <https://hg.mozilla.org/mozilla-central/rev/f875a4ffd653>.

The fix is the same as bug 255953 for www/firefox-esr.

[1] http://package22.nyi.freebsd.org/data/mainamd64PR255570-default/2021-05-08_16h02m24s/logs/thunderbird-78.10.0_1.log
Comment 1 commit-hook freebsd_committer 2021-05-18 08:39:40 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=5cfd4469d834c0bc282e8f0d2f45ede416290845

commit 5cfd4469d834c0bc282e8f0d2f45ede416290845
Author:     Christoph Moench-Tegeder <cmt@FreeBSD.org>
AuthorDate: 2021-05-18 08:37:34 +0000
Commit:     Christoph Moench-Tegeder <cmt@FreeBSD.org>
CommitDate: 2021-05-18 08:37:34 +0000

    mail/thunderbird: fix build with clang/libc++12

    PR:             255954
    Reported by:    dim
    Obtained from:  https://bugzilla.mozilla.org/show_bug.cgi?id=1694575

 mail/thunderbird/files/patch-bug1694575 (new) | 33 +++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
Comment 2 commit-hook freebsd_committer 2021-05-18 08:40:42 UTC
A commit in branch 2021Q2 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=e6b0a4d6272751fa08cee3e1d083b2574b1ec3c8

commit e6b0a4d6272751fa08cee3e1d083b2574b1ec3c8
Author:     Christoph Moench-Tegeder <cmt@FreeBSD.org>
AuthorDate: 2021-05-18 08:37:34 +0000
Commit:     Christoph Moench-Tegeder <cmt@FreeBSD.org>
CommitDate: 2021-05-18 08:40:04 +0000

    mail/thunderbird: fix build with clang/libc++12

    PR:             255954
    Reported by:    dim
    Obtained from:  https://bugzilla.mozilla.org/show_bug.cgi?id=1694575

    (cherry picked from commit 5cfd4469d834c0bc282e8f0d2f45ede416290845)

 mail/thunderbird/files/patch-bug1694575 (new) | 33 +++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
Comment 3 Christoph Moench-Tegeder freebsd_committer 2021-05-18 08:42:58 UTC
"works for me" and current gecko products, so here we go. Thanks.