Bug 255960 - games/freecell-solver failing to build on FreeBSD 12.2-p6 AMD64
Summary: games/freecell-solver failing to build on FreeBSD 12.2-p6 AMD64
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Danilo Egea Gondolfo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-18 03:43 UTC by Christopher
Modified: 2021-06-03 20:43 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (danilo)


Attachments
Full portmaster build output (52.08 KB, text/plain)
2021-05-18 03:43 UTC, Christopher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher 2021-05-18 03:43:16 UTC
Created attachment 225052 [details]
Full portmaster build output

Failing to build on FreeBSD 12.2-p6 AMD64

Build ends with:

ninja: build stopped: subcommand failed.
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/games/freecell-solver
*** Error code 1

Stop.
make: stopped in /usr/ports/games/freecell-solver

===>>> make build failed for games/freecell-solver
===>>> Aborting update


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> games/freecell-solver

Full process log attached.

Any thoughts or suggestions would be greatly appreciated.
Comment 1 Danilo Egea Gondolfo freebsd_committer 2021-05-18 20:14:23 UTC
Hi,

I can't reproduce the issue in a FreeBSD 12.2 jail. It simply works.

Although, I noticed you have Perl 5.30.3 installed. In my jail Perl 5.32.1 is being installed by default during the build.

You probably have the package perl5.30 installed. Is that a requirement or you can install perl5 (5.32)?
Comment 2 Christopher 2021-05-19 03:50:42 UTC
Thank you so much for looking into this.  It's appreciated.

I tried the port on a new computer with a freshly installed FreeBSD 13, Perl 5.32 and like you said... it just worked and installed with no issues.

The 12.2 machine in question has had been through many FreeBSD versions (upgrades) and perhaps it's time to just backup the home drive one last time and install FreeBSD 13 fresh and all the needed ports.  The last python38 upgrade was a complete disaster for us and although I thought I had fixed everything; perhaps, I missed something.

Long story short... I can confirm the port seems fine and the problem is most likely with this local machine and not the port.

I will try upgrading Perl first, before a fresh install (just to confirm if that was the problem) and will update this report once I have done that.  The machine is currently tied up... but I will get to this in the next day or so.

Thanks Again!
Comment 3 Christopher 2021-06-03 20:42:58 UTC
I am sorry but I forgot to test this further before upgrading everything to FreeBSD 13.  With the latest version this port simply works fine; so, it probably was the older Perl version.

Thanks so much for the help and I am sorry, for the trouble.

I will close this bug report now.