Bug 255961 - RPI 3B+ single user mode locks up
Summary: RPI 3B+ single user mode locks up
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: arm (show other bugs)
Version: 13.0-RELEASE
Hardware: arm64 Any
: --- Affects Only Me
Assignee: freebsd-arm (Nobody)
Depends on:
Reported: 2021-05-18 03:49 UTC by JJ Day
Modified: 2021-05-19 02:08 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description JJ Day 2021-05-18 03:49:00 UTC
I installed FreeBSD-13.0-RELEASE-arm64-aarch64-memstick.img to a new RPI 3B+. I added packages, users, etc. and ran for a couple of days for burn-in. Everything went well until I tried to boot single user. It froze during the boot and the only keyboard sequence I found that worked was <cntl> <alt> <del>.
I re-booted to multi-user and tried "# shutdown now" to get to single user and had the same result as booting directly to single user mode.
Any suggestions?

Comment 1 JJ Day 2021-05-18 04:00:39 UTC
Wrong installation file listed. Should be:
Comment 2 Bob Prohaska 2021-05-19 02:08:18 UTC
I believe you'll find that single user on the RPI requires a
serial connection. Haven't checked comprehensively, at least not
lately, but AFAIK only u-boot and multi-user work with a USB keyboard.
bob prohaska