Bug 255994 - www/chromium: virtual_oss dependency remove or make optional
Summary: www/chromium: virtual_oss dependency remove or make optional
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-chromium (Nobody)
URL:
Keywords:
: 255995 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-19 09:45 UTC by Oleh Hushchenkov
Modified: 2021-06-20 11:13 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (chromium)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleh Hushchenkov 2021-05-19 09:45:53 UTC
virtual_oss is not a runtime dependency for chromium. You need to configure it before using, so it won't help you if it's installed with chromium. And it's useless with ALSA(alsa-lib supports asound.conf) and PulseAudio, both can select audio input/output.

Now it forced to be installed even if won't be used. virtual_oss dependency should be removed or be optional and enabled by default with only SNDIO backend.
Comment 1 Li-Wen Hsu freebsd_committer 2021-05-19 09:48:44 UTC
*** Bug 255995 has been marked as a duplicate of this bug. ***
Comment 2 Rene Ladan freebsd_committer 2021-06-20 10:42:45 UTC
The dependency on virtual_oss has been removed in 8c17a97d68ab369d5be30d90d5720b260e520efd.
Comment 3 Oleh Hushchenkov 2021-06-20 11:13:20 UTC
(In reply to Rene Ladan from comment #2)
I also noticed that java is not need for build anymore. It's great news.

Thank you, Rene.