Bug 256047 - 3rd crash since upgrading to FreeBSD 13.0
Summary: 3rd crash since upgrading to FreeBSD 13.0
Status: Closed DUPLICATE of bug 257627
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 13.0-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords: panic, regression
Depends on:
Blocks:
 
Reported: 2021-05-21 02:45 UTC by doctor
Modified: 2021-08-26 09:51 UTC (History)
3 users (show)

See Also:


Attachments
core dump (417.25 KB, text/plain)
2021-05-21 02:45 UTC, doctor
no flags Details
additional info files (509 bytes, text/plain)
2021-05-21 02:46 UTC, doctor
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description doctor 2021-05-21 02:45:42 UTC
Created attachment 225142 [details]
core dump

3rd crash since upgrading to FreeBSD 13.0
Comment 1 doctor 2021-05-21 02:46:28 UTC
Created attachment 225143 [details]
additional info files

info file attached
Comment 2 Aleksandr Fedorov freebsd_committer 2021-05-22 08:44:25 UTC
It looks like this is a problem in pf.
Comment 3 Kristof Provost freebsd_committer 2021-05-22 09:12:12 UTC
(In reply to Aleksandr Fedorov from comment #2)
That looks a lot like PR 254419, but that should be fixed by  https://cgit.freebsd.org/src/commit/?id=b93a796b06ec013a75a08ac43d8acf6aa94aa970

Mark, do we also need to mb_unmapped_to_ext() in pf_check_proto_checksum() when called in the TX path?
Comment 4 Mark Johnston freebsd_committer 2021-05-22 16:06:40 UTC
(In reply to Kristof Provost from comment #3)
Hmm.  That could be the problem here indeed.  But it is kind of weird to crash only after a few days, as happened in this case.

To the submitter, are you able to reproduce the crash with kern.ipc.mb_use_ext_pgs=0 configured?
Comment 5 doctor 2021-06-18 07:03:03 UTC
All right, I am up to p2.  Is that fixed in p2?
Comment 6 Mark Johnston freebsd_committer 2021-06-18 13:10:42 UTC
(In reply to doctor from comment #5)
I don't think so.  Please see the question in comment 4.
Comment 7 Kristof Provost freebsd_committer 2021-08-26 09:51:58 UTC

*** This bug has been marked as a duplicate of bug 257627 ***