Bug 256066 - contrib/flex version is out of date
Summary: contrib/flex version is out of date
Status: Closed DUPLICATE of bug 239058
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: Unspecified
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-22 05:05 UTC by Ozkan KIRIK
Modified: 2021-06-22 03:17 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ozkan KIRIK 2021-05-22 05:05:26 UTC
The flex version in source tree is out of date. The latest version of flex is 2.6.4 (release date 06 May 2017) at https://github.com/westes/flex/tags, but source tree has the version 2.5.37.
Is it possible to update ?

Most of the ports that dependso on flex (for example snort3), find the base system's flex while in configure step. So that installing latest flex from ports doesn't solve issues.
Comment 1 Mark Johnston freebsd_committer 2021-06-02 16:21:14 UTC
flex 2.6.4 was imported almost a year ago and is included in FreeBSD 13.0: https://cgit.freebsd.org/src/commit/?id=7e38239042df09edbbdc443ccb4825f9155c6bb7
Comment 2 Mark Johnston freebsd_committer 2021-06-16 14:38:09 UTC
Is there anything that needs to be done for this PR?
Comment 3 Ozkan KIRIK 2021-06-21 14:45:25 UTC
But the flex version on FreeBSD stable/12 is out of date
Comment 4 Mark Johnston freebsd_committer 2021-06-21 15:05:11 UTC
(In reply to Ozkan KIRIK from comment #3)
Ok.  As I understand it we require packages for 12.x to build on 12.0, so workarounds for an outdated flex are required anyway.  But I will defer to Jung-uk on this since he does the work to maintain flex in the tree.
Comment 5 Jung-uk Kim freebsd_committer 2021-06-21 20:32:23 UTC
Unfortunately, Flex 2.6.4 introduced a regression.  Please see Bug 253440.  Although it was worked around by 4e3fa977a14f, I have no intention to update stable/12 at the time.  Sorry, you will have to use flex from the ports tree.

*** This bug has been marked as a duplicate of bug 239058 ***
Comment 6 Jung-uk Kim freebsd_committer 2021-06-21 20:38:33 UTC
(In reply to Ozkan KIRIK from comment #0)
Is there any feature you need from the latest Flex?
Comment 7 Ozkan KIRIK 2021-06-22 03:17:50 UTC
What is opened the bug report, the security/snort3 port couldn't detect the flex from ports. The cmake configure was detecting the flex from system altough flex from ports was installed. This problem was fixed later. Now security/snort3 configure step can detect the flex from ports.