Bug 256131 - lang/mecrisp-stellaris: upgrade to 2.5.9
Summary: lang/mecrisp-stellaris: upgrade to 2.5.9
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Only Me
Assignee: Juraj Lutter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-24 19:19 UTC by Robert Clausecker
Modified: 2021-06-10 08:16 UTC (History)
1 user (show)

See Also:
fuz: maintainer-feedback+
fuz: merge-quarterly?


Attachments
lang/mecrisp-stellaris: upgrade to 2.5.9 (3.36 KB, patch)
2021-05-24 19:19 UTC, Robert Clausecker
fuz: maintainer-approval+
Details | Diff
lang/mecrisp-stellaris: upgrade to 2.5.9 (4.32 KB, patch)
2021-06-01 12:39 UTC, Robert Clausecker
fuz: maintainer-approval+
Details | Diff
lang/mecrisp-stellaris: upgrade to 2.5.9 (4.57 KB, patch)
2021-06-09 13:35 UTC, Robert Clausecker
fuz: maintainer-approval+
Details | Diff
arm64/13.0-RELEASE poudriere testport log (67.76 KB, text/plain)
2021-06-09 20:17 UTC, Robert Clausecker
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Clausecker 2021-05-24 19:19:36 UTC
Created attachment 225231 [details]
lang/mecrisp-stellaris: upgrade to 2.5.9

This patch upgrades the port lang/mecrisp-stellaris to the newly released version 2.5.9.  It also removes a patch that has been integrated upstream and changes pkg-message to only display on arm64 as it is not relevant to armv6 and armv7.
Comment 1 Robert Clausecker 2021-05-24 19:21:25 UTC
I'm not sure if MFH is appropriate here.  2.5.9 is mainly a patch release; the only relevant change is that the special patch for FreeBSD is now integrated into the project.
Comment 2 Robert Clausecker 2021-06-01 12:39:34 UTC
Created attachment 225450 [details]
lang/mecrisp-stellaris: upgrade to 2.5.9

Upgrade patch with one that addresses some portlint warnings.

portlint: OK (2 unfixable warnings remain)
testport: OK (poudriere: 13arm64, 13armv7; manually: 13Rarmv6)
unittest: n/a
Comment 3 Juraj Lutter freebsd_committer 2021-06-09 06:59:15 UTC
install   -m 555 /wrkdirs/usr/ports/lang/mecrisp-stellaris/work/mecrisp-stellaris-2.5.8/freebsd-ra/mecrisp-stellaris-freebsd-with-disassembler-and-math /wrkdirs/usr/ports/lang/mecrisp-stellaris/work/stage/usr/local/bin/mecrisp-stellaris
install: /wrkdirs/usr/ports/lang/mecrisp-stellaris/work/mecrisp-stellaris-2.5.8/freebsd-ra/mecrisp-stellaris-freebsd-with-disassembler-and-math: No such file or directory
*** Error code 71
Comment 4 Robert Clausecker 2021-06-09 07:27:51 UTC
(In reply to Juraj Lutter from comment #3)

Huch?  This is strange.  I had tested the update beforehand.  Could you send me the full poudriere tesport log please so I can investigate this?

Yours,
Robert Clausecker
Comment 5 Robert Clausecker 2021-06-09 07:55:20 UTC
(In reply to Juraj Lutter from comment #3)

It appears the port does not build on arm64 with QEMU.  This is because
it tries to execute armv7 binaries which QEMU doesn't like when built
for arm64.  Please test this port in a native environment.

I'll look into ways to ensure that the port is IGNORE'd under emulated arm64.
Comment 6 Robert Clausecker 2021-06-09 13:35:37 UTC
Created attachment 225660 [details]
lang/mecrisp-stellaris: upgrade to 2.5.9

IGNORE package when building for aarch64 under QEMU.

A native builder is needed to produce an aarch64 package.
Comment 7 Robert Clausecker 2021-06-09 20:17:00 UTC
Created attachment 225670 [details]
arm64/13.0-RELEASE poudriere testport log

Poudriere log attached as per request given on IRC.
Comment 8 commit-hook freebsd_committer 2021-06-09 21:41:29 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=0ff18039417542a3b95cad650ab3bd5cede1c04a

commit 0ff18039417542a3b95cad650ab3bd5cede1c04a
Author:     Robert Clausecker <fuz@fuz.su>
AuthorDate: 2021-06-09 21:38:08 +0000
Commit:     Juraj Lutter <otis@FreeBSD.org>
CommitDate: 2021-06-09 21:39:55 +0000

    lang/mecrisp-stellaris: Update to 2.5.9

    - Update to 2.5.9
    - Remove a patch that has been upstreamed

    PR:             256131

 lang/mecrisp-stellaris/Makefile                    | 14 ++++++++----
 lang/mecrisp-stellaris/distinfo                    |  6 +++---
 ...p-stellaris-source_freebsd-ra_terminal.s (gone) | 25 ----------------------
 3 files changed, 13 insertions(+), 32 deletions(-)
Comment 9 Robert Clausecker 2021-06-09 22:26:36 UTC
Reopening this: the patch attachment 225660 [details] was applied incorrectly: the rename of pkg-message to pkg-message-aarch64 was missed, causing the message to not be displayed on any architecture.

Please fix this if possible.
Comment 10 commit-hook freebsd_committer 2021-06-10 05:59:07 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=fb887fe458fa9185dd46dbe80c3c5fc707afc709

commit fb887fe458fa9185dd46dbe80c3c5fc707afc709
Author:     Juraj Lutter <otis@FreeBSD.org>
AuthorDate: 2021-06-10 05:29:55 +0000
Commit:     Juraj Lutter <otis@FreeBSD.org>
CommitDate: 2021-06-10 05:57:16 +0000

    lang/mecrisp-stellaris: Fix pkg-message

    - Rename pkg-message file as intended in the PR.
      `git apply' should have been used instead of `patch'.
    - Bump PORTREVISION

    PR:             256131
    Reported by:    Robert Clausecker <fuz@fuz.su> (maintainer)

 lang/mecrisp-stellaris/Makefile                             | 1 +
 lang/mecrisp-stellaris/{pkg-message => pkg-message-aarch64} | 0
 2 files changed, 1 insertion(+)
Comment 11 Robert Clausecker 2021-06-10 08:16:54 UTC
That did the trick!