Bug 256151 - x11/konsole profile set to /bin/sh: Warning: Could not find an interactive shell to start.
Summary: x11/konsole profile set to /bin/sh: Warning: Could not find an interactive sh...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-kde (Team)
URL: https://bugs.kde.org/show_bug.cgi?id=...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-25 14:38 UTC by Graham Perrin
Modified: 2021-06-04 10:39 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-05-25 14:38:32 UTC
Spun off from <https://forums.freebsd.org/threads/80286/>: 

1. create a new profile

2. set its command to /bin/sh

3. open a new tab using the profile

> Warning: Could not find an interactive shell to start.

### Workaround

4. edit the profile to use sh (without specifying a path)

### Environment

% date ; freebsd-version ; uname -KU
Tue 25 May 2021 15:36:14 BST
14.0-CURRENT
1400013 1400013
% pkg info -x konsole
konsole-21.04.1
% grep url /etc/pkg/FreeBSD.conf 
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",
% ls -hl /bin/sh
-r-xr-xr-x  1 root  wheel   168K 15 May 14:33 /bin/sh
% file /bin/sh
/bin/sh: ELF 64-bit LSB pie executable, x86-64, version 1 (FreeBSD), dynamically linked, interpreter /libexec/ld-elf.so.1, for FreeBSD 14.0 (1400013), FreeBSD-style, stripped
%
Comment 1 Adriaan de Groot freebsd_committer 2021-06-01 21:13:59 UTC
Somewhat peculiar: if I enter
 /bin/tcsh
 /bin/csh
 /usr/local/bin/bash
as command, all of those are fine. It's only /bin/sh that triggers this. And more strangely yet, /bin/sh is explicitly listed as the most-fallback-iest of shells.
Comment 2 Graham Perrin 2021-06-02 01:38:54 UTC
Thank you, 

(In reply to Adriaan de Groot from comment #1)

> … only /bin/sh that triggers this …

Should we treat this bug 256151 as a duplicate of the earlier KDE bug? 

(Sorry, I should have searched there before opening a bug here.)
Comment 3 Graham Perrin 2021-06-04 04:33:47 UTC
My installation was fixed with a 2021-05-30 patch from tcberner@ 

Following my confirmation of success (2021-05-31) with the patch, in IRC: 

> ok, I'll commit it, thanks for testing

Kurt Hindenburg (2021-06-03) at <https://bugs.kde.org/show_bug.cgi?id=436242#c7>: 

> … Adriaan and I basically came up with the same patch. …
Comment 4 Adriaan de Groot freebsd_committer 2021-06-04 10:39:14 UTC
Added to ports in 897891227032