Bug 256183 - emulators/open-vm-tools: Fails to build after devel/glib20 update
Summary: emulators/open-vm-tools: Fails to build after devel/glib20 update
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Neel Chauhan
URL:
Keywords: needs-patch, needs-qa, regression
Depends on:
Blocks: 256282
  Show dependency treegraph
 
Reported: 2021-05-27 08:57 UTC by Christian Ullrich
Modified: 2021-08-18 19:29 UTC (History)
6 users (show)

See Also:
koobs: maintainer-feedback? (nc)
koobs: maintainer-feedback? (garga)
koobs: merge-quarterly?


Attachments
Patch. (759 bytes, text/plain)
2021-05-27 08:57 UTC, Christian Ullrich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ullrich 2021-05-27 08:57:03 UTC
Created attachment 225302 [details]
Patch.

This morning's update of devel/glib20 to release 2.68.2 broke the build of open-vm-tools due to an API change.

The attached patch lets it build again, but I cannot say whether the patch is correct. Anything with the word "volatile" in it is scary.
Comment 1 Tobias C. Berner freebsd_committer 2021-05-27 09:06:52 UTC
Moin moin 

Thanks for the report.

@nc please take a look at this, and consider to (read: do) request exp-runs in the future.


mfg Tobias
Comment 2 Dima Panov freebsd_committer 2021-06-03 13:49:30 UTC
Keep for the future updates: upstream has own, more complete solution.

https://github.com/vmware/open-vm-tools/commit/82931a1bcb39d5132910c7fb2ddc086c51d06662
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-14 04:22:51 UTC
Upstream backport likely the better option here. Build regression needs to be landed and merged prior to update to 11.3.0 (bug 256282)
Comment 4 Renato Botelho freebsd_committer 2021-08-18 19:29:04 UTC
open-vm-tools already has patches and build fine with latest glib20