Bug 256369 - games/lbreakout2 is out-of-date
Summary: games/lbreakout2 is out-of-date
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-02 07:12 UTC by Christopher
Modified: 2021-06-04 05:51 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher 2021-06-02 07:12:33 UTC
The creator of lbreakout2 has discontinued support of this port in favor of lbreakouthd....

For those that have corrupt display issues with lbreakout2 the newly released replacemtn of lbreakouthd reports it's fixes most of those issues.

I see there's no maintainer for this dead port; perhaps I might make an attempt at filling that role... not sure... but it's an intriguing idea as it's only a game and I might learn something along the way...

Any who... those who are having trouble with lbreakout2 it's because it's way out of date and there is a replacement out there... just not on FreeBSD (yet).
Comment 1 Fernando Apesteguía freebsd_committer 2021-06-03 07:18:59 UTC
Hi Christopher,

games/lbreakout2 is not out of date. As I see in the web page, 2.6.5 is the last released version and that is the one we have in ports. Since this is the case, how about we close this PR?

You are right, there is no port for lbreakouthd. You can give it a try and port it if you want. Have a look at the Porter's Handbook (https://docs.freebsd.org/en/books/porters-handbook/book.html) and also use games/lbreakout2 as a reference. You can ask in the mail lists too to find advice.

Once you have a functional port, you can open a new PR.

What do you think?
Comment 2 Christopher 2021-06-03 21:03:06 UTC
Thanks for the feedback...

Looking back on this, my description was poorly worded and I apologize.

It's not that the port is out of date as you point out; it's that the "author" of LBreakout2 has publicly announced that he is not maintaining this anymore. Instead, is directing people to the newer and maintained LBreakoutHD.

(listed in bold red here:  https://lgames.sourceforge.io/LBreakout2/ )

I am all for leaving older, unmaintained software around... as such things can still help users.

I just get confused as I keep tripping over ports that are dropped quickly because upstream has discontinued support and yet other's don't get dropped.

And, again I am fine with that... I just don't understood where the line is drawn as it seems to be both very stringent and yet flexible all at the same time.

But... I am interested in learning, so I'll see what I can do with the porter's handbook.

Thanks again and I will close this PR.
Comment 3 Fernando Apesteguía freebsd_committer 2021-06-04 05:51:22 UTC
(In reply to Christopher from comment #2)

As someone said "The Ports collection is not a museum" :)

But, yeah, the fact that a port is not maintained anymore or even discontinued does not necessarily mean that it should be removed. If the port works just fine _and people use it_, it is fine to keep it. From time to time a deleted port is resurrected after a number of people complain. It is not irreversible.