Bug 256388 - graphics/libepoxy: fix gl=libglvnd,mesa-* and X11=off
Summary: graphics/libepoxy: fix gl=libglvnd,mesa-* and X11=off
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-02 19:44 UTC by Evgeniy Khramtsov
Modified: 2021-08-15 21:39 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)
kbowling: merge-quarterly-


Attachments
patch (2.41 KB, patch)
2021-06-02 19:44 UTC, Evgeniy Khramtsov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Evgeniy Khramtsov 2021-06-02 19:44:24 UTC
Created attachment 225508 [details]
patch

1.5.8 reverted two commits that caused regressions under certain conditions for Xorg, but regressed Wayland-only environments where libGL does not exist and OpenGL is provided by libOpenGL instead.

Fix Wayland-only environments by making a reverted patch conditional when X11=off.

The current 1.5.8 in ports breaks at least www/webkit2-gtk3 for libglvnd and Wayland-only:

Couldn't open libGL.so.1: Shared object "libGL.so.1" not found
Comment 1 Niclas Zeising freebsd_committer 2021-06-03 13:07:57 UTC
Has this patch been submitted and merged upstream?
Comment 2 Niclas Zeising freebsd_committer 2021-06-03 13:10:22 UTC
I think I found the commit:
https://github.com/anholt/libepoxy/commit/dbfa4b209c0712b67dfeb8366c2ebe8503063b52
If that's the case, the patch is already included in the release.
Comment 3 Niclas Zeising freebsd_committer 2021-06-03 13:20:05 UTC
I might be confused.  There is, however, also this commit
https://github.com/anholt/libepoxy/commit/622ca393c38a92e2fac9f877bbcf65f97782d206
That seem to revert the change in 1.5.8.
Comment 4 Niclas Zeising freebsd_committer 2021-06-03 13:29:05 UTC
Ok, I figured it out.
The patches were reverted upstream in 1.5.8 because they caused regressions.  Before including this patch again, please confer with upstream on how to best handle the situation.  I would very much prefer not to add this as a local patch as possible, especially since it has both been committed and reverted upstream.
Comment 5 Evgeniy Khramtsov 2021-06-03 17:27:04 UTC
(In reply to Niclas Zeising from comment #4)

OK. There is https://github.com/anholt/libepoxy/pull/232 though it doesn't get much activity. Thanks for reply, I'll leave bug open so the libGL message is searchable.
Comment 6 Warner Losh freebsd_committer 2021-06-28 18:17:45 UTC
This is a big can of worms. The right place to get this fixed is upstream since there's several issues noted in the linked info from upstream. Given the issues it caused upstream, we've opted to not include this patch. Once upstream sorts it out we'll get it on the next update.
Comment 7 Kevin Bowling freebsd_committer 2021-06-28 20:49:07 UTC
Talked with upstream,  https://github.com/anholt/libepoxy/pull/257 will fix this.  I'll reopen this and use it as a self reminder.
Comment 8 Kevin Bowling freebsd_committer 2021-06-29 23:04:22 UTC
x11, koobs, are you ok with me pulling in this patch to our tree for testing?  We can report success or failure to upstream to help get it in a release.  This one looks low risk to me because it prefers the existing setup (GLX) and therefore the increased risk is heavily weighted to the !X11 option.
Comment 9 Kevin Bowling freebsd_committer 2021-06-30 00:47:33 UTC
(In reply to Kevin Bowling from comment #8)
To clarify, https://github.com/anholt/libepoxy/pull/257, not the patch that was backed out.
Comment 10 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-03 00:52:42 UTC
(In reply to Kevin Bowling from comment #9)

Changes that fix build issues (build, configure, package, etc) and are QA'd are:

Approved by: portmgr (blanket: <target> fix)
MFH: <$branch|No) (<reason>)

Committers may self-assign and resolve at any time under those conditions
Comment 11 Niclas Zeising freebsd_committer 2021-07-03 07:59:18 UTC
Since the original patch suggested here is a patch that was committed and then backed out, and since there is an ongoing discussion upstream on how to solve this, I ask, with my x11@ hat on, to please hold off on committing the patch in this PR or the suggested patch from upstream, until the upstream discussion reaches a solution and a patch has been merged upstream.
Comment 12 commit-hook freebsd_committer 2021-08-15 21:37:57 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=9d0a715765c5e723cc0fc872b6b1eab862dbcb73

commit 9d0a715765c5e723cc0fc872b6b1eab862dbcb73
Author:     Kevin Bowling <kbowling@FreeBSD.org>
AuthorDate: 2021-08-15 21:34:45 +0000
Commit:     Kevin Bowling <kbowling@FreeBSD.org>
CommitDate: 2021-08-15 21:34:45 +0000

    graphics/libepoxy: Update to 1.5.9

    There is one change which fixes a regression with libOpenGL:
    "Allow libopengl.so to be used when GLX_LIB is missing"

    PR:             256388
    Approved by:    x11 (zeising)

 graphics/libepoxy/Makefile | 3 +--
 graphics/libepoxy/distinfo | 6 +++---
 2 files changed, 4 insertions(+), 5 deletions(-)