Bug 256396 - Assignee field in Bugzilla does not autocomplete
Summary: Assignee field in Bugzilla does not autocomplete
Status: Closed Works As Intended
Alias: None
Product: Services
Classification: Unclassified
Component: Bug Tracker (show other bugs)
Version: unspecified
Hardware: Any Any
: --- Affects Only Me
Assignee: Kubilay Kocak
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-06-03 06:01 UTC by Fernando Apesteguía
Modified: 2021-06-06 00:19 UTC (History)
1 user (show)

See Also:


Attachments
autocomplete screenshot (9.78 KB, image/png)
2021-06-05 00:01 UTC, Kubilay Kocak
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fernando Apesteguía freebsd_committer 2021-06-03 06:01:25 UTC
"Assignee" field in bugzilla does not autocomplete anymore.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-06-05 00:01:33 UTC
Created attachment 225557 [details]
autocomplete screenshot

Unable to reproduce here. I believe thre's a minimum character count before it begins to autocomplete. Might be 3 chars iirc.

What string is being entered that doesn't autocomplete?
Comment 2 Fernando Apesteguía freebsd_committer 2021-06-05 16:10:59 UTC
(In reply to Kubilay Kocak from comment #1)
I tried in this PR:https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256201

Typing "as" to assign the PR to asomers@. I'm pretty sure I ended up copying the email address because it either did not autocomplete or it was super slow. The three characters you mention sound right because typing "aso" does autocomplete.

I will close this and keep an eye on this in case I can reproduce it.

Thanks for checking this.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2021-06-06 00:19:56 UTC
yep, so Bugzilla's autocomplete extension has a min 2 char requirement before autocompleting for performance reasons, made more challenging because we have a huge list.

We've (I've) considered possible improvements to this, where we 'disable' (or exclude) accounts that haven't signed in for greater than <period> for auto-completion, which may open up the door for auto-completing with less input characters.