Bug 256412 - 13.0-RELEASE amd64 DVD .iso is too big to burn on 4.7GB DVD-R
Summary: 13.0-RELEASE amd64 DVD .iso is too big to burn on 4.7GB DVD-R
Status: Closed DUPLICATE of bug 255057
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 13.0-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-04 10:41 UTC by Vincent Bentley
Modified: 2021-07-21 19:26 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Bentley 2021-06-04 10:41:28 UTC
I needed to create a physical boot DVD for 13.0-RELEASE as my memory stick image for 13.0 would not boot on the old 64-bit PC I was working on. From memory, the 13.0-RELEASE amd64 DVD image needs to lose about 100MB-200MB to fit on a 4.7GB DVD.

This only affects those needing a 13.0-RELEASE image on physical DVD media.

The issue is similar to open bug 253483 that refers to 13-STABLE
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=253483

Also similar to closed bug 255057 that refers to 13-STABLE
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255057
Comment 1 Graham Perrin 2021-06-05 16:05:59 UTC
Duplicate of bug 253483
Comment 2 Graham Perrin 2021-06-05 16:09:23 UTC
… sorry, I see that you already referenced 253483. I imagine that another report is not required.
Comment 3 Vincent Bentley 2021-06-07 12:49:05 UTC
The other two reports concern STABLE which is accepted that some things will be broken due to continuous change. However, I have raised this because the bug found it's way to RELEASE where there is a general expectation that things will be less broken. I only wanted to raise awareness that this bug found it's way to the 13.0-RELEASE version.
Comment 4 sergey 2021-07-14 22:29:39 UTC
Same here but I have dvd-rw ;)
Comment 5 unitrunker 2021-07-18 01:23:38 UTC
As a workaround, if someone could document how to use the DVD iso image on a USB drive - that would help greatly.

Right now folks are wasting time and bandwidth downloading an image they can't use.
Comment 6 Graham Perrin 2021-07-18 02:30:54 UTC
(In reply to unitrunker from comment #5)

> … how to use the DVD iso image on a USB drive …

I always used dd, as outlined under 
<https://docs.freebsd.org/en/books/handbook/bsdinstall/#bsdinstall-usb>

– use the .iso file as the input file. 

The computer might do as well with a USB drive from an .iso file as it would do with a USB drive from an .img file. <https://forums.FreeBSD.org/threads/57687/post-523224>

An example with gdd(1) instead of dd(1): 

gdd status=progress bs=10M if=/⋯/⋯.iso of=/dev/da⋯

----

% pkg provides usr/local/bin/gdd
Name    : coreutils-8.32
Desc    : Free Software Foundation core utilities
Repo    : FreeBSD
Filename: usr/local/bin/gdd
% pkg query %o coreutils
sysutils/coreutils
% 

<https://www.freshports.org/sysutils/coreutils/>
Comment 7 unitrunker 2021-07-18 03:12:50 UTC
(In reply to Graham Perrin from comment #6)

Thanks Graham. Just got back from purchasing a pair of cheap 8GB USB sticks. About to try this out.
Comment 8 unitrunker 2021-07-18 04:19:51 UTC
(In reply to Graham Perrin from comment #6)

I'm able to boot on at least one machine with this image on USB.
Comment 9 Glen Barber freebsd_committer 2021-07-21 19:26:06 UTC

*** This bug has been marked as a duplicate of bug 255057 ***