Bug 256420 - audio/carla: last update breaks lmms package build
Summary: audio/carla: last update breaks lmms package build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-06-04 21:48 UTC by Rodrigo Osorio
Modified: 2021-06-05 07:24 UTC (History)
0 users

See Also:
koobs: maintainer-feedback+
koobs: merge-quarterly-


Attachments
restore USE_LDCONFIG in carla port (661 bytes, patch)
2021-06-04 21:48 UTC, Rodrigo Osorio
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Osorio freebsd_committer 2021-06-04 21:48:47 UTC
Created attachment 225554 [details]
restore USE_LDCONFIG in carla port

The last update for audio/carla removes the USE_LDCONFIG
variable and breaks audio/lmms during dependency check.

The attached patch restores the removed declaration and expands
it to other subdirectories and bumps PORTREVISION.
Comment 1 Yuri Victorovich freebsd_committer 2021-06-04 22:55:00 UTC
Hi Rodrigo,


Thanks for the patch, and sorry for breaking audio/lmms.

.lv2 and .vst files don't need USE_LDCONFIG because they are plugins and their discovery mechanism is different.

I committed the minimally necessary USE_LDCONFIG.


Thanks,
Yuri
Comment 2 commit-hook freebsd_committer 2021-06-04 22:56:13 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=7620e258ef9d255c73beb70a085366eef1915a62

commit 7620e258ef9d255c73beb70a085366eef1915a62
Author:     Yuri Victorovich <yuri@FreeBSD.org>
AuthorDate: 2021-06-04 22:48:58 +0000
Commit:     Yuri Victorovich <yuri@FreeBSD.org>
CommitDate: 2021-06-04 22:55:12 +0000

    audio/carla: Fix build of audio/lmms by re-adding USE_LDCONFIG.

    Last update removed USE_LDCONFIG based on a bad recommendation from portlint.

    Also move CONFLICTS_BUILD to the right place.

    PR:             256420
    Reported by:    rodrigo

 audio/carla/Makefile | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
Comment 3 Rodrigo Osorio freebsd_committer 2021-06-05 07:24:50 UTC
Thanks Youri.

Cheers,
-- rodrigo