Bug 256421 - XOpenDisplay: <X11/Xlib.h> is not displayed in the web version of the manpage
Summary: XOpenDisplay: <X11/Xlib.h> is not displayed in the web version of the manpage
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Website (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-doc (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-05 00:31 UTC by Hodong
Modified: 2021-06-10 15:54 UTC (History)
4 users (show)

See Also:


Attachments
libX11-1.6.4 (216.04 KB, image/png)
2021-06-10 14:53 UTC, Hodong
no flags Details
libX11-1.6.9 (229.44 KB, image/png)
2021-06-10 14:55 UTC, Hodong
no flags Details
libX11-1.6.12,1 (112.23 KB, image/png)
2021-06-10 14:58 UTC, Hodong
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hodong 2021-06-05 00:31:35 UTC
Hello.
I use FreeBSD 13.

In terminal and website, "<X11/Xlib.h>" is not displayed.

https://www.freebsd.org/cgi/man.cgi?query=XOpenDisplay&apropos=0&sektion=0&manpath=FreeBSD+13.0-RELEASE+and+Ports&arch=default&format=html

% man XOpenDisplay
...

       If successful, XOpenDisplay returns a pointer to a Display structure,
       which is defined in If XOpenDisplay does not succeed, it returns NULL.
...


See below:

https://www.x.org/releases/X11R7.5/doc/man/man3/XOpenDisplay.3.html

If successful, XOpenDisplay returns a pointer to a Display structure, which is defined in <X11/Xlib.h>.
           ^^^^^^^^^^^^^
Comment 1 Niclas Zeising freebsd_committer 2021-06-10 08:24:59 UTC
This has to do with the pre-rendered man pages on www.freebsd.org, and nothing to do with the X11 ports.
Comment 2 Alexey Dokuchaev freebsd_committer 2021-06-10 08:39:20 UTC
(In reply to Hodong from comment #0)
> In terminal and website, "<X11/Xlib.h>" is not displayed.
> See below: https://www.x.org/releases/X11R7.5/doc/man/man3/XOpenDisplay.3.html
The upstream link you posted also does not display #include <X11/Xlib.h> in the synopsis (which is, I presume, what are you complaining about) and likewise only mentions it in the description.  Why are you filing the bug against FreeBSD and not X.Org?

(In reply to Niclas Zeising from comment #1)
> This has to do with the pre-rendered man pages on www.freebsd.org
This has nothing to do with pre-rendered man pages.  Did you actually try typing "man XOpenDisplay" in your terminal?
Comment 3 Hodong 2021-06-10 10:59:37 UTC
(In reply to Alexey Dokuchaev from comment #2)

> Why are you filing the bug against FreeBSD and not X.Org?

It is displayed properly on the x.org homepage and in the Linux terminal. If so, what should I report there?

First off, it's a bug that the man page doesn't display properly. So I wrote a bug report against FreeBSD.

There seems to be a difference between FreeBSD and Linux in how the man pages are rendered. How should I approach this issue?
Comment 4 Alexey Dokuchaev freebsd_committer 2021-06-10 12:05:21 UTC
(In reply to Hodong from comment #3)
> It is displayed properly on the x.org homepage
Are you referring to the link you've posted earlier?  If yes, then it looks pretty much identical to what I see on my FreeBSD installation, and it does not mention #include <X11/Xlib.h> until the "... Display structure, which is defined in" part.

> First off, it's a bug that the man page doesn't display properly.
First off, you need to demonstrate the difference, I still don't see it.
Comment 5 Alexey Dokuchaev freebsd_committer 2021-06-10 12:11:43 UTC
(In reply to Hodong from comment #0)
> In terminal and website, "<X11/Xlib.h>" is not displayed.
Ah, OK, I see it now, the website does not render it correctly indeed, but it is correctly displayed on the terminal.

(In reply to Alexey Dokuchaev from comment #2)
> This has nothing to do with pre-rendered man pages.
Apparently I was wrong, the problem is indeed with web version of this manpage.
Comment 6 Hodong 2021-06-10 14:53:46 UTC
Created attachment 225702 [details]
libX11-1.6.4

In libX11-1.6.4 it is displayed correctly.
Comment 7 Hodong 2021-06-10 14:55:16 UTC
Created attachment 225703 [details]
libX11-1.6.9

In libX11-1.6.9 it is displayed incorrectly.
Comment 8 Hodong 2021-06-10 14:58:22 UTC
Created attachment 225704 [details]
libX11-1.6.12,1

This appears to be a libx11 documentation bug. There seems to be a bug in the documentation from some version.
Comment 9 Hodong 2021-06-10 15:05:59 UTC
This documentation bug is also reproducible in Ubuntu 20.04 terminal and FreeBSD 13 terminal. I will report a bug to x.org as soon as possible.
Comment 11 Hodong 2021-06-10 15:54:57 UTC
(In reply to Hodong from comment #10)

Alan Coopersmith said it was already fixed.

https://gitlab.freedesktop.org/xorg/lib/libx11/-/commit/14fb4e535626ba934cad5bc4308f511524cd1103