Bug 256469 - net/freeradius3: after the update to 3.0.22 it appears that EAP authentication is broken
Summary: net/freeradius3: after the update to 3.0.22 it appears that EAP authenticatio...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ryan Steinmetz
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-06-07 15:58 UTC by Dean E. Weimer
Modified: 2021-06-08 00:26 UTC (History)
0 users

See Also:
koobs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dean E. Weimer 2021-06-07 15:58:46 UTC
After the update to 3.0.22 it appears that EAP authentication is broken. 


Mon Jun  7 10:54:42 2021 : Error: rlm_eap (EAP): Failed to link rlm_eap_leap: Cannot open "/usr/local/lib/freeradius-3.0.22/rlm_eap_leap.so"
Mon Jun  7 10:54:42 2021 : Error: /usr/local/etc/raddb/mods-enabled/eap[14]: Instantiation failed for module "eap"
Comment 1 Ryan Steinmetz freebsd_committer freebsd_triage 2021-06-07 19:59:53 UTC
EAP still works fine.  Based on your log snippet, it looks like you are using LEAP.

LEAP was removed in FreeRADIUS 3.0.22.  Per the release notes:
- Remove native support for Cisco LEAP. It is insecure, and should not be used. Proxying LEAP is still supported.