Bug 256519 - devel/lua-gettext: update to 1.6
Summary: devel/lua-gettext: update to 1.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Vanilla I. Shu
URL:
Keywords: dogfood, easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2021-06-09 23:52 UTC by Chris Hutchinson
Modified: 2021-06-12 04:09 UTC (History)
1 user (show)

See Also:


Attachments
git diff for devel/lua-gettext (3.11 KB, patch)
2021-06-09 23:52 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff
git diff for devel/lua-gettext (version 2) (3.11 KB, patch)
2021-06-10 05:49 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2021-06-09 23:52:50 UTC
Created attachment 225681 [details]
git diff for devel/lua-gettext

While there's nothing wrong with this port,
it works as intended. It's suffering from a
bit of rot. So I wanted to look at making
some changes to this and find there's no to
contact the original author.
I'm hijacking it -- it's pointless to be a
maintainer, if you can't maintain it. ;-)
Anyway. I added a license, moved hosting to
GitLab in an effort to get more attention.
I'm currently working on making the minimum
lua version start at 52.

Changes
Makefile

Additions
README's
CHANGELOG
LICENSE

make (check-plist|stage-qa|check-sanity|portlint) return AOK
on 12 && 13 amd64

That's it.

Thanks!

--Chris
Comment 1 Chris Hutchinson 2021-06-10 05:49:58 UTC
Created attachment 225686 [details]
git diff for devel/lua-gettext (version 2)

This is cleaner and tidier. The last one
was a bit messy.
passes all tests on 12 and 13 amd64

Thanks!
Comment 2 Vanilla I. Shu freebsd_committer 2021-06-12 04:08:43 UTC
Committed, thanks.
Comment 3 commit-hook freebsd_committer 2021-06-12 04:09:20 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=e28c8b7317a5874a73da91992e0fbc0b7bac2b80

commit e28c8b7317a5874a73da91992e0fbc0b7bac2b80
Author:     Vanilla I. Shu <vanilla@FreeBSD.org>
AuthorDate: 2021-06-12 04:06:31 +0000
Commit:     Vanilla I. Shu <vanilla@FreeBSD.org>
CommitDate: 2021-06-12 04:06:31 +0000

    devel/lua-gettext: update to 1.6

    PR:             256519
    Reported by:    maintainer

 devel/lua-gettext/Makefile  | 41 +++++++++++++++++++++--------------------
 devel/lua-gettext/distinfo  |  8 ++++----
 devel/lua-gettext/pkg-descr |  4 +++-
 3 files changed, 28 insertions(+), 25 deletions(-)