Bug 256530 - dns/powerdns-recursor: update to 4.5.2 + rc.d script changes + cleanup deps
Summary: dns/powerdns-recursor: update to 4.5.2 + rc.d script changes + cleanup deps
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kevin Bowling
URL: https://doc.powerdns.com/recursor/cha...
Keywords:
: 255842 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-06-10 07:54 UTC by Ralf van der Enden
Modified: 2021-06-12 12:36 UTC (History)
1 user (show)

See Also:


Attachments
update PowerDNS Recursor to 4.5.2 + rc.d script changes + cleanup deps (2.95 KB, patch)
2021-06-10 07:54 UTC, Ralf van der Enden
tremere: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf van der Enden 2021-06-10 07:54:45 UTC
Created attachment 225694 [details]
update PowerDNS Recursor to 4.5.2 + rc.d script changes + cleanup deps

Q&A:
poudriere: testport ok (13.0-RELEASE;amd64;)
Makefile portclippy/portmft processed


Also mark NOT_FOR_ARCHS=i386 since upstream no longer supports archs with 32bit time_t
Comment 1 commit-hook freebsd_committer 2021-06-11 16:54:21 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=f008c3a2ef2021778c768b1a49d241566f45b93b

commit f008c3a2ef2021778c768b1a49d241566f45b93b
Author:     Ralf van der Enden <tremere@cainites.net>
AuthorDate: 2021-06-11 16:38:22 +0000
Commit:     Kevin Bowling <kbowling@FreeBSD.org>
CommitDate: 2021-06-11 16:51:14 +0000

    dns/powerdns-recursor: update to 4.5.2

    rc.d script changes + cleanup deps

    mark NOT_FOR_ARCHS=i386 since upstream no longer supports archs with
    32bit time_t.

    Changes: https://doc.powerdns.com/recursor/changelog/4.5.html#change-4.5.2

    PR:             256530
    Approved by:    maintainer

 dns/powerdns-recursor/Makefile               | 13 ++++++-------
 dns/powerdns-recursor/distinfo               |  6 +++---
 dns/powerdns-recursor/files/pdns-recursor.in |  7 ++++++-
 3 files changed, 15 insertions(+), 11 deletions(-)
Comment 2 Kevin Bowling freebsd_committer 2021-06-11 16:57:52 UTC
Thanks for your contribution!
Comment 3 Kevin Bowling freebsd_committer 2021-06-11 16:59:00 UTC
*** Bug 255842 has been marked as a duplicate of this bug. ***