Bug 256539 - devel/safe-iop: update to 0.32
Summary: devel/safe-iop: update to 0.32
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Neel Chauhan
URL:
Keywords: dogfood, easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2021-06-10 18:15 UTC by Chris Hutchinson
Modified: 2021-06-11 20:27 UTC (History)
1 user (show)

See Also:


Attachments
git diff for devel/safe-iop (3.48 KB, patch)
2021-06-10 18:15 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff
git diff for devel/safe-iop (3.48 KB, patch)
2021-06-10 18:21 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2021-06-10 18:15:07 UTC
Created attachment 225713 [details]
git diff for devel/safe-iop

I use this port, and while it works as intended.
It's suffering a bit of rot. So I'd like to move
it forward. Move source to GitLab to encourage
participation. Perform a bit of cleanup, add
READMEs, a license, and bump version to 0.32.

That pretty much covers it.

Please find the attached git diff for greater detail.

Thanks! :-)

--Chris
Comment 1 Chris Hutchinson 2021-06-10 18:21:21 UTC
Created attachment 225714 [details]
git diff for devel/safe-iop

git diff Version 2
Forgot to nuke a line in the last one. :-/

Sorry.

--Chris
Comment 2 Chris Hutchinson 2021-06-10 18:36:47 UTC
OH forgot to mention:
builds/installs && deinstalls as intended on 12 and 13 amd64
===>  License BSD2CLAUSE accepted by the user
===>   safe-iop-0.3.2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by safe-iop-0.3.2 for building
===>  Extracting for safe-iop-0.3.2
=> SHA256 Checksum OK for ports1-safe-iop-2b20d77fb9f22b1ec9e2b3d2eb53c532596d3203_GL0.tar.gz.
===>  Patching for safe-iop-0.3.2
===>  Configuring for safe-iop-0.3.2
===>  Building for safe-iop-0.3.2
--- so ---
====> Compressing man pages (compress-man)
====> Running Q/A tests (stage-qa)
===>  Installing for safe-iop-0.3.2
===>  Checking if safe-iop is already installed
===>   Registering installation for safe-iop-0.3.2
[dev13current.localhost] Installing safe-iop-0.3.2...
===>  Cleaning for safe-iop-0.3.2

===>  Deinstalling for safe-iop
===>   Deinstalling safe-iop-0.3.2
Updating database digests format: 100%
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
	safe-iop: 0.3.2

Number of packages to be removed: 1
[dev13current.localhost] [1/1] Deinstalling safe-iop-0.3.2...
[dev13current.localhost] [1/1] Deleting files for safe-iop-0.3.2: 100%

Now you know. :-)
Comment 3 Neel Chauhan freebsd_committer 2021-06-11 20:26:20 UTC
Committed!
Comment 4 commit-hook freebsd_committer 2021-06-11 20:27:05 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=4cf514c377a56d7b705d85baffc408d24bdcbebe

commit 4cf514c377a56d7b705d85baffc408d24bdcbebe
Author:     Chris Hutchinson <portmaster@bsdforge.com>
AuthorDate: 2021-06-11 20:26:10 +0000
Commit:     Neel Chauhan <nc@FreeBSD.org>
CommitDate: 2021-06-11 20:26:10 +0000

    devel/safe-iop: update to 0.32

    PR:     256539

 devel/safe-iop/Makefile  | 33 +++++++++++++++++++++++----------
 devel/safe-iop/distinfo  |  6 ++++--
 devel/safe-iop/pkg-descr |  8 ++++----
 3 files changed, 31 insertions(+), 16 deletions(-)