Bug 256543 - devel/tailor: update to 0.9.37
Summary: devel/tailor: update to 0.9.37
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Neel Chauhan
URL:
Keywords: dogfood, easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2021-06-10 22:03 UTC by Chris Hutchinson
Modified: 2021-06-11 20:24 UTC (History)
1 user (show)

See Also:


Attachments
git diff for devel/tailor (2.33 KB, patch)
2021-06-10 22:03 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2021-06-10 22:03:40 UTC
Created attachment 225718 [details]
git diff for devel/tailor

I've been cobbling on and using this for awhile.
But it's time to update this and host it on GitLab
to get some more input.
I've added some stuff, moved some stuff around and
updated/corrected some of the docs. Tag it 0.9.37.

Please find git diff attached for details.

Thanks! :-)

builds/installs/works/uninstalls as intended on
12 and 13 amd64

===> Fetching all distfiles required by tailor-0.9.37 for building
===>  Extracting for tailor-0.9.37
=> SHA256 Checksum OK for ports1-tailor-06d9068d84a4e78f30579fbdc46ed22ec9d953c7_GL0.tar.gz.
===>  Patching for tailor-0.9.37
===>   tailor-0.9.37 depends on package: py37-future>0 - found
===>   tailor-0.9.37 depends on package: py37-setuptools>0 - found
===>   tailor-0.9.37 depends on file: /usr/local/bin/python3.7 - found
===>  Configuring for tailor-0.9.37
running config
===>  Building for tailor-0.9.37
...
====> Compressing man pages (compress-man)
====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
===> Checking for items in pkg-plist which are not in STAGEDIR
===> No pkg-plist issues found (check-plist)
...
===>  Deinstalling for tailor
===>   Deinstalling tailor-0.9.37
Updating database digests format: 100%
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
	tailor: 0.9.37

Number of packages to be removed: 1

The operation will free 1 MiB.
[dev13current.localhost] [1/1] Deinstalling tailor-0.9.37...
[dev13current.localhost] [1/1] Deleting files for tailor-0.9.37: 100%


--Chris
Comment 1 Neel Chauhan freebsd_committer 2021-06-11 20:23:43 UTC
Committed!
Comment 2 commit-hook freebsd_committer 2021-06-11 20:24:03 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=df2cb225d0f18bb648d40d555b2070e6e48a2bfe

commit df2cb225d0f18bb648d40d555b2070e6e48a2bfe
Author:     Chris Hutchinson <portmaster@bsdforge.com>
AuthorDate: 2021-06-11 20:23:24 +0000
Commit:     Neel Chauhan <nc@FreeBSD.org>
CommitDate: 2021-06-11 20:23:38 +0000

    devel/tailor: update to 0.9.37

    PR:     256543

 devel/tailor/Makefile  | 13 +++++++++----
 devel/tailor/distinfo  |  7 ++++---
 devel/tailor/pkg-descr |  2 +-
 3 files changed, 14 insertions(+), 8 deletions(-)