Bug 256619 - devel/safe-iop: fix LICENSE
Summary: devel/safe-iop: fix LICENSE
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kevin Bowling
URL:
Keywords: dogfood, easy
Depends on:
Blocks:
 
Reported: 2021-06-15 16:07 UTC by Chris Hutchinson
Modified: 2021-07-07 02:16 UTC (History)
1 user (show)

See Also:
kbowling: merge-quarterly+


Attachments
git diff for devel/safe-iop (691 bytes, patch)
2021-06-15 16:07 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff
git diff for devel/safe-iop: adds LICENSE_NAME to quell pkg-fallout@ (423 bytes, patch)
2021-07-06 17:40 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff
build log for devel/safe-iop (2.79 KB, text/plain)
2021-07-06 17:42 UTC, Chris Hutchinson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2021-06-15 16:07:38 UTC
Created attachment 225829 [details]
git diff for devel/safe-iop

I attempted to subvert the license framework.
That was wrong. Fix it.

This is a dead simple patch.

Thanks!

--Chris
Comment 1 commit-hook freebsd_committer 2021-06-15 16:10:39 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=73182d47e75a4f1082f75a9360a285b964f04e9b

commit 73182d47e75a4f1082f75a9360a285b964f04e9b
Author:     Chris Hutchinson <portmaster@bsdforge.com>
AuthorDate: 2021-06-15 16:09:41 +0000
Commit:     Kevin Bowling <kbowling@FreeBSD.org>
CommitDate: 2021-06-15 16:09:41 +0000

    devel/safe-iop: fix LICENSE

    PR:             256619
    Approved by:    maintainer

 devel/safe-iop/Makefile | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)
Comment 2 Kevin Bowling freebsd_committer 2021-06-15 16:10:56 UTC
Thanks for your contribution!
Comment 3 Chris Hutchinson 2021-06-15 16:18:06 UTC
(In reply to Kevin Bowling from comment #2)
Thank you for yours! :-)
Comment 4 Chris Hutchinson 2021-06-29 17:38:44 UTC
This doesn't appear to have been committed.
As I am still getting messages from pkgfallout@
for errors involving the PREVIOUS version, eg;
package - main-i386-default][devel/safe-iop]
Failed for safe-iop-0.3.2 in check-sanity...

When will this commit hit the pkg builders | what
else must be done to make the change in this pr "stick"?

Thanks! :-)

--Chris
Comment 5 Chris Hutchinson 2021-06-29 17:45:49 UTC
(In reply to Chris Hutchinson from comment #4)
Followup...
I can confirm that THIS version is in the ports
tree. So it simply hasn't hit the pkg builders.
MFC?

Thanks again.

--Chris
Comment 6 Kevin Bowling freebsd_committer 2021-06-30 00:59:26 UTC
(In reply to Chris Hutchinson from comment #5)
Hi Chris.  Since this patch was on top of the version bump it doesn't cherry-pick cleanly.  I think the easiest route is to wait two more days for the next quarterly to branch.
Comment 7 Chris Hutchinson 2021-06-30 16:53:58 UTC
(In reply to Kevin Bowling from comment #6)
Sure, OK. Will do.

Thanks, Kevin.

--Chris
Comment 8 Chris Hutchinson 2021-07-06 17:40:51 UTC
Created attachment 226272 [details]
git diff for devel/safe-iop: adds LICENSE_NAME to quell pkg-fallout@

OK I waited as instructed. After the quarterly got cut, I
continued to get complaints from the package builders.
So today I checked out a copy of the ports tree and set
out to determine what was wrong. Apparently something was
different from the version of the ports tree I was using
and the one I checked out today. As the build DID complain
about the LICENSE block. I have fixed the complaint.
wanted;
LICENSE_NAME
which is provided in the attached git diff.
I am also providing the build log for proof/inspection.
This was performed on 13/amd64.

Thanks you! :-)

--Chris
Comment 9 Chris Hutchinson 2021-07-06 17:42:08 UTC
Created attachment 226274 [details]
build log for devel/safe-iop

The build log as promised.
Comment 10 Chris Hutchinson 2021-07-06 17:43:17 UTC
New git diff and build log for safe-iop.

--Chris
Comment 11 commit-hook freebsd_committer 2021-07-07 01:18:04 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=1430cb47fa0748e9dd6a7cf1640f74a72cb5eb5a

commit 1430cb47fa0748e9dd6a7cf1640f74a72cb5eb5a
Author:     Chris Hutchinson <portmaster@bsdforge.com>
AuthorDate: 2021-07-07 01:16:11 +0000
Commit:     Kevin Bowling <kbowling@FreeBSD.org>
CommitDate: 2021-07-07 01:17:01 +0000

    devel/safe-iop: fix LICENSE

    PR:             256619

 devel/safe-iop/Makefile | 1 +
 1 file changed, 1 insertion(+)
Comment 12 commit-hook freebsd_committer 2021-07-07 01:20:05 UTC
A commit in branch 2021Q3 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=efe3f3e34d09659540798f396d5908b5315490a0

commit efe3f3e34d09659540798f396d5908b5315490a0
Author:     Chris Hutchinson <portmaster@bsdforge.com>
AuthorDate: 2021-07-07 01:16:11 +0000
Commit:     Kevin Bowling <kbowling@FreeBSD.org>
CommitDate: 2021-07-07 01:18:53 +0000

    devel/safe-iop: fix LICENSE

    PR:             256619
    (cherry picked from commit 1430cb47fa0748e9dd6a7cf1640f74a72cb5eb5a)

 devel/safe-iop/Makefile | 1 +
 1 file changed, 1 insertion(+)
Comment 13 Chris Hutchinson 2021-07-07 02:16:29 UTC
Thanks for doing this, Kevin! :-)

--Chris