Bug 256706 - ports-mgmt/poudriere: ports infrastructure change denies poudriere -a with python flavors
Summary: ports-mgmt/poudriere: ports infrastructure change denies poudriere -a with py...
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-06-19 04:12 UTC by dgilbert
Modified: 2021-06-19 06:04 UTC (History)
5 users (show)

See Also:
koobs: maintainer-feedback? (bdrewery)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dgilbert 2021-06-19 04:12:07 UTC
I have python 3.7 set as the default.  It is important to me that this change is managed... and I'm not ready to use 3.8 yet.

Today, when I went to build with poudriere -a, it chucked out a whole mess of the following:

[00:02:27] Error: compute_deps_pkg failed to lookup pkgname for databases/py-apsw@py38 processing package calibre-5.21.0 from deskutils/calibre -- Is SUBDIR+=py-apsw@py38 missing in databases/Makefile and does the port provide the 'py38' FLAVOR?

and _one_ like this:

[00:02:27] Warning: deskutils/calibre dependency on net/py-zeroconf has wrong PKGNAME of 'py38-zeroconf' but should be 'py37-zeroconf'

... I understand that -a should build all the flavors, but building with -a worked last month (I do it about once a month) and it doesn't work this month.

my make.conf  contains:

DEFAULT_VERSIONS+=python=3.7
DEFAULT_VERSIONS+=python3=3.7
DEFAULT_VERSIONS+=pgsql=10
DEFAULT_VERSIONS+=django=2.2
DEFAULT_VERSIONS+=dj=2.2
DEFAULT_VERSIONS+=php=74

SELECTED_OPTIONS+=OPENBLAS

ARCHDEF=AMD64K10h64SSE3
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-06-19 04:24:33 UTC
^Triage: Classify as poudriere issue until isolated
Comment 2 Guido Falsi freebsd_committer 2021-06-19 06:04:38 UTC
The calibre port has a minimum requirement of python 3.8. This is due to upstream development targeting that version and the code actually including statements incompatible with python 3.7

Not sure if this is a problem with the framework or calibre. Calibre port should not compile or correct requirements be provided by the infrastructure.

calibre port is not generating flavors AFAIK, and I don't think it should.