Bug 256716 - graphics/swftools: [PATCH] allow building without X11 / OPENGL
Summary: graphics/swftools: [PATCH] allow building without X11 / OPENGL
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-19 14:22 UTC by Palle Girgensohn
Modified: 2021-07-04 18:22 UTC (History)
2 users (show)

See Also:
dinoex: maintainer-feedback+


Attachments
add option for OPENGL (901 bytes, patch)
2021-06-19 14:22 UTC, Palle Girgensohn
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Palle Girgensohn freebsd_committer 2021-06-19 14:22:47 UTC
Created attachment 225932 [details]
add option for OPENGL

Since most or our machines are headless, x11 is just an unecessary complication.

When building with 

OPTIONS_UNSET?= X11 NLS OPENGL

in make.conf

swftools fails, since it depends in libGLU that does nbot build without X11 [1]

I s´suggest an option to build swftools without OPENGL. Perhaps it's even better to depend on the X11 option´, I'm not sure?

Palle


[1]:
===>   libGLU-9.0.1 depends on shared library: libGL.so - not found
===>   Installing existing package /packages/All/libglvnd-1.3.2.txz
[122-amd64-git-job-01] Installing libglvnd-1.3.2...
[122-amd64-git-job-01] Extracting libglvnd-1.3.2: .......... done
===>   libGLU-9.0.1 depends on shared library: libGL.so - not found
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/libGLU
Comment 1 Dirk Meyer freebsd_committer 2021-07-02 06:29:24 UTC
looks fine, but has regressions.
I will update the patch.
Comment 2 commit-hook freebsd_committer 2021-07-04 18:06:44 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=95bdad8226f71d5a74c9d217d9ff65a622b0685a

commit 95bdad8226f71d5a74c9d217d9ff65a622b0685a
Author:     Dirk Meyer <dinoex@FreeBSD.org>
AuthorDate: 2021-07-04 18:06:17 +0000
Commit:     Dirk Meyer <dinoex@FreeBSD.org>
CommitDate: 2021-07-04 18:06:17 +0000

    graphics/swftools: new option OPENGL

    PR:             256716
    Submitted by:   Palle Girgensohn

 graphics/swftools/Makefile | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)
Comment 3 Dirk Meyer freebsd_committer 2021-07-04 18:22:33 UTC
Commited with small changes