Bug 256839 - net-im/nheko: Doesn't show chats, missing dependency: graphics/qt5-graphicaleffects: [qml] [warning] qrc:/qml/TimelineView.qml:10:1: module "QtGraphicalEffects" is not installed
Summary: net-im/nheko: Doesn't show chats, missing dependency: graphics/qt5-graphicale...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Adriaan de Groot
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2021-06-25 22:50 UTC by Filipe da Silva Santos
Modified: 2021-06-26 22:12 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (adridg)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filipe da Silva Santos 2021-06-25 22:50:17 UTC
Please, add graphics/qt5-graphicaleffect as a library dependency.
Without that dependency, nheko starts up, but won't show anything.

```
[2021-06-25 19:36:16.603] [qml] [warning] qrc:/qml/TimelineView.qml:10:1: module "QtGraphicalEffects" is not installed
```
Comment 1 Adriaan de Groot freebsd_committer 2021-06-26 21:33:22 UTC
Confirmed in a 13- VBox with just XOrg, twm and nheko installed.
Comment 2 commit-hook freebsd_committer 2021-06-26 22:03:19 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=e0f0a32d502af6eb619fd0c377de644492673fa4

commit e0f0a32d502af6eb619fd0c377de644492673fa4
Author:     Adriaan de Groot <adridg@FreeBSD.org>
AuthorDate: 2021-06-26 22:00:26 +0000
Commit:     Adriaan de Groot <adridg@FreeBSD.org>
CommitDate: 2021-06-26 22:03:09 +0000

    net-im/nheko: add missing dependency

    At runtime, qt5-graphicaleffects are needed to display anything
    in the timeline (e.g. a conversation in a room). Even the loading-
    spinner isn't shown without it. Demonstrated by trying to run
    nheko in a "bare" machine with just XOrg and twm.

    PR:             256839
    Reported by:    Filipe da Silva Santos

 net-im/nheko/Makefile | 2 ++
 1 file changed, 2 insertions(+)
Comment 3 commit-hook freebsd_committer 2021-06-26 22:11:22 UTC
A commit in branch 2021Q2 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=3a6240c2127867111d6eb18e39f539e35e3ffad7

commit 3a6240c2127867111d6eb18e39f539e35e3ffad7
Author:     Adriaan de Groot <adridg@FreeBSD.org>
AuthorDate: 2021-06-26 22:00:26 +0000
Commit:     Adriaan de Groot <adridg@FreeBSD.org>
CommitDate: 2021-06-26 22:09:36 +0000

    net-im/nheko: add missing dependency

    At runtime, qt5-graphicaleffects are needed to display anything
    in the timeline (e.g. a conversation in a room). Even the loading-
    spinner isn't shown without it. Demonstrated by trying to run
    nheko in a "bare" machine with just XOrg and twm.

    PR:             256839
    Reported by:    Filipe da Silva Santos

    [[ Cherry pick is not exact because quarterly has an older version,
       but the runtime requirement is still there. ]]
    (cherry picked from commit e0f0a32d502af6eb619fd0c377de644492673fa4)

 net-im/nheko/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)