Bug 256858 - net-mgmt/wifimgr: Cannot reset interface wlan0 - exit status 2.
Summary: net-mgmt/wifimgr: Cannot reset interface wlan0 - exit status 2.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-27 08:34 UTC by Graham Perrin
Modified: 2021-07-03 14:52 UTC (History)
2 users (show)

See Also:
fbsd: maintainer-feedback+


Attachments
patch to update port from 1.14 to 1.15 (1.81 KB, patch)
2021-06-27 14:47 UTC, J.R. Oldroyd
no flags Details | Diff
patch to update port from 1.14 to 1.16 (1.13 KB, patch)
2021-06-28 11:26 UTC, J.R. Oldroyd
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-06-27 08:34:03 UTC
A click on the 'Save and Reconnect' button leads to: 

1. a red alert dialogue, pictured at 
  <https://forums.freebsd.org/attachments/2021-06-26-17-20-02-png.10328/>

2. unexpected closure of the application (and presumably, no reconnection). 

% wifimgr
sh: Syntax error: "(" unexpected
% pkg info -x wifimgr
wifimgr-1.14
% date ; uname -KUv
Sun 27 Jun 2021 09:30:58 BST
FreeBSD 14.0-CURRENT #99 main-n247565-b49ba74deeb: Sat Jun 26 02:36:29 BST 2021     root@mowa219-gjp4-8570p:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG  1400024 1400024
% 

----

I see that bug 202602 was not a bug; that was for a different exit status (1).
Comment 1 J.R. Oldroyd 2021-06-27 14:47:49 UTC
Created attachment 226077 [details]
patch to update port from 1.14 to 1.15

Thanks for spotting this, Graham.  Patch to fix included here.

Note to committer:

A patch was included (perhaps by the wifimgr-1.14 committer ?) that is not part of the upstream source and which breaks things.  Please remove that patch:
    files/patch-src_Makefile

Thanks.
Comment 2 J.R. Oldroyd 2021-06-28 11:26:58 UTC
Created attachment 226087 [details]
patch to update port from 1.14 to 1.16

I have done further work to update wifimgr from gtk2 to gtk3.

Version 1.16 supersedes version 1.15:
  - gtk3 support
  - fix error clearing ssid of cloaked network
  - remove debug printf left in 1.15 by mistake

Note to committer:

In comment 1, above, I asked to remove files/patch-src_Makefile.  In fact, I see now that that patch is ok as the suid bit is set in the plist.  So, please ignore comment 1.
Comment 3 commit-hook freebsd_committer 2021-07-02 06:11:02 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=6384046d5f9b7b4f738d3d03a8b64a0a81af38af

commit 6384046d5f9b7b4f738d3d03a8b64a0a81af38af
Author:     Fernando Apesteguía <fernape@FreeBSD.org>
AuthorDate: 2021-07-01 07:57:13 +0000
Commit:     Fernando Apesteguía <fernape@FreeBSD.org>
CommitDate: 2021-07-02 06:06:07 +0000

    net-mgmt/wifimgr: update to 1.16

    This fixes some problems like the one in the PR:

    "Cannot reset interface wlan0 - exit status 2."

    PR:     256858
    Reported by:    grahamperrin@gmail.com
    Tested by:      fbsd@opal.com (maintainer)

 net-mgmt/wifimgr/Makefile | 8 ++++----
 net-mgmt/wifimgr/distinfo | 5 +++--
 2 files changed, 7 insertions(+), 6 deletions(-)
Comment 4 Fernando Apesteguía freebsd_committer 2021-07-02 06:11:28 UTC
Committed,

Thanks!
Comment 5 Graham Perrin 2021-07-03 14:52:51 UTC
Thanks! Building now, I'll test soon.