Bug 256940 - math/lapack manpages.tgz unfetchable
Summary: math/lapack manpages.tgz unfetchable
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thierry Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-02 17:40 UTC by alt2600
Modified: 2021-07-02 21:23 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (fortran)


Attachments
Patch for math/lapack/distinfo and math/lapack/files/manpages (2.89 KB, patch)
2021-07-02 18:38 UTC, Trond.Endrestol
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description alt2600 2021-07-02 17:40:12 UTC
===>  License BSD3CLAUSE accepted by the user
===>   lapack-3.9.1 depends on file: /usr/local/sbin/pkg - found
=> manpages.tgz doesn't seem to exist in /usr/ports/distfiles//lapack.
=> Attempting to fetch http://www.netlib.org/lapack/manpages.tgz
fetch: http://www.netlib.org/lapack/manpages.tgz: size mismatch: expected 2391904, actual 2446510
=> Attempting to fetch https://ftp.mirrorservice.org/sites/ftp.netlib.org/lapack/manpages.tgz
fetch: https://ftp.mirrorservice.org/sites/ftp.netlib.org/lapack/manpages.tgz: size mismatch: expected 2391904, actual 2446510
=> Attempting to fetch https://www.mirrorservice.org/sites/ftp.netlib.org/lapack/manpages.tgz
fetch: https://www.mirrorservice.org/sites/ftp.netlib.org/lapack/manpages.tgz: size mismatch: expected 2391904, actual 2446510
=> Attempting to fetch ftp://ftp.irisa.fr/pub/netlib/lapack/manpages.tgz
fetch: ftp://ftp.irisa.fr/pub/netlib/lapack/manpages.tgz: size mismatch: expected 2391904, actual 1378304
=> Attempting to fetch http://netlib.sandia.gov/lapack/manpages.tgz
fetch: http://netlib.sandia.gov/lapack/manpages.tgz: size mismatch: expected 2391904, actual 2446510
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/lapack/manpages.tgz
fetch: http://distcache.FreeBSD.org/ports-distfiles/lapack/manpages.tgz: Not Found
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles//lapack and try again.
*** Error code 1
Comment 1 Trond.Endrestol 2021-07-02 18:38:53 UTC
Created attachment 226175 [details]
Patch for math/lapack/distinfo and math/lapack/files/manpages

Try this patch, although at your own risk:

git -C /usr/ports apply < /path/to/math_lapack.diff

A committer should probably verify the accuracy of the distinfo file or even recreate it.

IHTH.
Comment 2 Thierry Thomas freebsd_committer 2021-07-02 21:21:24 UTC
(In reply to Trond.Endrestol from comment #1)
Thanks, but actually the problem is that a new version has been released, but the manpages are not versioned, and you get the pages for 3.10.0.
Comment 3 Thierry Thomas freebsd_committer 2021-07-02 21:23:14 UTC
Fixed by upgrading to 3.10.0.
Comment 4 commit-hook freebsd_committer 2021-07-02 21:23:26 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=34dc18b257de7c1313e2c32a1e61b8c5646cc73d

commit 34dc18b257de7c1313e2c32a1e61b8c5646cc73d
Author:     Thierry Thomas <thierry@FreeBSD.org>
AuthorDate: 2021-07-02 21:13:24 +0000
Commit:     Thierry Thomas <thierry@FreeBSD.org>
CommitDate: 2021-07-02 21:20:45 +0000

    math/lapack: +math/blas et al., upgrade to 3.10.0

    - Upgrade math/blas, math/cblas, math/lapack, math/lapacke and math/xlapack
      to 3.10.0;
      Latest release notes at <http://netlib.org/lapack/lapack-3.10.0.html>

    - This is a major release and also addressing multiple bug fixes

    - The tarball is no more hosted by netlib but at GitHub

    - This also fixes the problem with unversioned manpages.

    PR:             256940
    Reported by:    alt2600 (at) icloud.com

 math/lapack/Makefile       |    11 +-
 math/lapack/distinfo       |    10 +-
 math/lapack/files/manpages | 10034 ++++++++++++++++++++++++++++++++++++++++++-
 math/lapack/pkg-plist      |     1 -
 4 files changed, 10029 insertions(+), 27 deletions(-)