Bug 256986 - tests/sys/netgraph attempts to build with WITHOUT_NETGRAPH= and fails
Summary: tests/sys/netgraph attempts to build with WITHOUT_NETGRAPH= and fails
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 13.0-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Ed Maste
URL:
Keywords:
: 257168 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-05 06:58 UTC by John Marshall
Modified: 2021-07-16 00:48 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Marshall 2021-07-05 06:58:53 UTC
rwsrv08> grep NETGRAPH /etc/src.conf
WITHOUT_NETGRAPH=		# Do not build ATM or BLUETOOTH

rwsrv08> make buildworld

--- util.o ---
cc -target x86_64-unknown-freebsd13.0 --sysroot=/build/obj/john/kits/src/rwsrv08/amd64.amd64/tmp -B/build/obj/john/kits/src/rwsrv08/amd64.amd64/tmp/usr/bin  -O2 -pipe -fno-common -march=sandybridge  -g  -std=gnu99 -Wno-format-zero-length -fstack-protector-strong -Wsystem-headers -Werror -Wall -Wno-format-y2k -W -Wno-unused-parameter -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wshadow -Wunused-parameter -Wcast-align -Wchar-subscripts -Wnested-externs -Wredundant-decls -Wold-style-definition -Wno-pointer-sign -Wmissing-variable-declarations -Wthread-safety -Wno-empty-body -Wno-string-plus-int -Wno-unused-const-variable  -Qunused-arguments    -c /kits/src/rwsrv08/tests/sys/netgraph/util.c -o util.o
In file included from /kits/src/rwsrv08/tests/sys/netgraph/util.c:42:
/kits/src/rwsrv08/tests/sys/netgraph/util.h:35:10: fatal error: 'netgraph.h' file not found
#include <netgraph.h>
         ^~~~~~~~~~~~
1 error generated.
*** [util.o] Error code 1

make[5]: stopped in /kits/src/rwsrv08/tests/sys/netgraph
Comment 1 commit-hook freebsd_committer 2021-07-06 13:47:59 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/src/commit/?id=c9144ec14d2a5a53cfe91ada1b3b9c06b78dc999

commit c9144ec14d2a5a53cfe91ada1b3b9c06b78dc999
Author:     Ed Maste <emaste@FreeBSD.org>
AuthorDate: 2021-07-06 13:44:15 +0000
Commit:     Ed Maste <emaste@FreeBSD.org>
CommitDate: 2021-07-06 13:45:34 +0000

    Skip netgraph tests when WITHOUT_NETGRAPH is set

    PR:             256986
    Reported by:    John Marshall
    MFC after:      1 week
    Sponsored by:   The FreeBSD Foundation

 tests/sys/Makefile | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
Comment 2 John Marshall 2021-07-09 06:14:08 UTC
Thanks Ed,

I fetched a fresh STABLE yesterday and applied your patch. STABLE builds and runs fine with WITHOUT_NETGRAPH. Thank you!
Comment 3 commit-hook freebsd_committer 2021-07-13 00:29:44 UTC
A commit in branch stable/13 references this bug:

URL: https://cgit.FreeBSD.org/src/commit/?id=ae2e05423dfff64cdfcf6263de6e62ef49dec6a0

commit ae2e05423dfff64cdfcf6263de6e62ef49dec6a0
Author:     Ed Maste <emaste@FreeBSD.org>
AuthorDate: 2021-07-06 13:44:15 +0000
Commit:     Ed Maste <emaste@FreeBSD.org>
CommitDate: 2021-07-13 00:27:19 +0000

    Skip netgraph tests when WITHOUT_NETGRAPH is set

    PR:             256986
    Reported by:    John Marshall
    MFC after:      1 week
    Sponsored by:   The FreeBSD Foundation

    (cherry picked from commit c9144ec14d2a5a53cfe91ada1b3b9c06b78dc999)

 tests/sys/Makefile | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
Comment 4 Ed Maste freebsd_committer 2021-07-16 00:37:04 UTC
*** Bug 257168 has been marked as a duplicate of this bug. ***
Comment 5 commit-hook freebsd_committer 2021-07-16 00:40:58 UTC
A commit in branch stable/12 references this bug:

URL: https://cgit.FreeBSD.org/src/commit/?id=feb1dc84d895bfb53b0b205a1b55b955ab32b0a5

commit feb1dc84d895bfb53b0b205a1b55b955ab32b0a5
Author:     Ed Maste <emaste@FreeBSD.org>
AuthorDate: 2021-07-06 13:44:15 +0000
Commit:     Ed Maste <emaste@FreeBSD.org>
CommitDate: 2021-07-16 00:39:34 +0000

    Skip netgraph tests when WITHOUT_NETGRAPH is set

    PR:             256986
    Reported by:    John Marshall
    MFC after:      1 week
    Sponsored by:   The FreeBSD Foundation

    (cherry picked from commit c9144ec14d2a5a53cfe91ada1b3b9c06b78dc999)

 tests/sys/Makefile | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
Comment 6 Ed Maste freebsd_committer 2021-07-16 00:48:07 UTC
Thanks for the report