Bug 257119 - x11-fonts/fontconfig: Update to 2.13.94
Summary: x11-fonts/fontconfig: Update to 2.13.94
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Daniel Engberg
URL: https://gitlab.freedesktop.org/fontco...
Keywords:
Depends on:
Blocks: 258145
  Show dependency treegraph
 
Reported: 2021-07-11 20:31 UTC by Daniel Engberg
Modified: 2021-09-05 17:06 UTC (History)
5 users (show)

See Also:
tcberner: maintainer-feedback+
antoine: exp-run+


Attachments
Patch for fontconfig (5.02 KB, patch)
2021-07-11 20:31 UTC, Daniel Engberg
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Engberg freebsd_committer 2021-07-11 20:31:34 UTC
Created attachment 226377 [details]
Patch for fontconfig

Update fontconfig to 2.13.94

Compile and tested on FreeBSD FreeBSD 13.0-STABLE #0 stable/13-n246086-a20c597c6d7 (amd64) (make, make check-plist, make test)
Poudriere testport OK 12.2-RELEASE (amd64)
Poudriere testport OK 11.4-RELEASE (amd64)
Comment 1 Daniel Engberg freebsd_committer 2021-07-11 20:32:44 UTC
Compile tested with following ports:
graphics/gd	
x11-toolkits/pango
x11-fonts/libXft
x11-toolkits/qt5-gui

...and appears to work as intended.
Comment 2 Daniel Engberg freebsd_committer 2021-07-11 20:36:37 UTC
Hi Ting-Wei,

Can you give this a try?

Best regards,
Daniel
Comment 3 Ting-Wei Lan 2021-08-08 17:08:09 UTC
(In reply to Daniel Engberg from comment #2)
I have tried it, and it seems to work fine.

By the way, I think it will be nice if we can have doc enabled under an option. The man page is often needed to debug font problems.
Comment 4 Tobias C. Berner freebsd_committer 2021-08-08 17:21:03 UTC
Moin moin 

desktop@ would like to ask for an exp-run of the provided patch.


mfg Tobias
Comment 5 Antoine Brodin freebsd_committer 2021-08-14 20:22:03 UTC
exp-run looks fine
Comment 6 commit-hook freebsd_committer 2021-08-15 06:22:11 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=83e384fbc4fd9d8af5d513f98913518bd78e021b

commit 83e384fbc4fd9d8af5d513f98913518bd78e021b
Author:     Daniel Engberg <diizzy@FreeBSD.org>
AuthorDate: 2021-08-15 06:13:06 +0000
Commit:     Daniel Engberg <diizzy@FreeBSD.org>
CommitDate: 2021-08-15 06:15:36 +0000

    x11-fonts/fontconfig: Update to 2.13.94

    Changelog:
    https://gitlab.freedesktop.org/fontconfig/fontconfig/-/blob/main/README

    PR:             257119
    Approved by:    tcberner (mentor)
    Exp-run by:     antoine

 x11-fonts/fontconfig/Makefile                      |  3 +-
 x11-fonts/fontconfig/distinfo                      |  6 ++--
 x11-fonts/fontconfig/files/patch-meson.build       | 20 +++++------
 .../fontconfig/files/patch-src_fccfg.c (gone)      | 42 ----------------------
 4 files changed, 14 insertions(+), 57 deletions(-)
Comment 7 Daniel Engberg freebsd_committer 2021-08-15 07:21:39 UTC
(In reply to Ting-Wei Lan from comment #3)
Unfortunately that introduces circular dependency unless we somehow package prebuilt ones.
Comment 8 John Hein 2021-08-16 18:18:59 UTC
bug 254963 still applies after the update to 2.13.94

After the update to meson, 'make stage' now tries to run 'fc-cache' (see fc-cache/meson.build) which tries to write to /usr/local rather than work/stage.  So, of course, when running 'make stage' as a regular user (poudriere SHOULD be doing this really), you hit permissions problems.
Comment 9 Ting-Wei Lan 2021-08-22 16:34:51 UTC
(In reply to Daniel Engberg from comment #7)
If we can install prebuilt man pages, it is much better than providing no man pages at all.
Comment 10 Ting-Wei Lan 2021-08-29 15:40:38 UTC
I opened bug 258145 for installing prebuilt documentation files.
Comment 11 Daniel Engberg freebsd_committer 2021-09-05 17:06:30 UTC
Committed