Bug 257139 - math/lapack: Fix broken lib symlink
Summary: math/lapack: Fix broken lib symlink
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Thierry Thomas
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-07-12 17:09 UTC by John Hein
Modified: 2021-07-18 15:58 UTC (History)
2 users (show)

See Also:
thierry: maintainer-feedback+
thierry: merge-quarterly+


Attachments
[patch] math/lapack: remove unnecessary post-install for libtmglib shared libs (1.21 KB, patch)
2021-07-12 17:09 UTC, John Hein
jcfyecrayz: maintainer-approval? (fortran)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2021-07-12 17:09:36 UTC
Created attachment 226405 [details]
[patch] math/lapack: remove unnecessary post-install for libtmglib shared libs

In lapack-3.10.0, there is a broken sym link for libtmglib.so.3.10.0 (should be a file):

/usr/local/lib/libtmglib.so.3@ -> libtmglib.so.3.10.0
/usr/local/lib/libtmglib.so.3.10.0@ -> libtmglib.so.3


Just remove the unnecessary code in post-install for libtmglib shared lib files.  'do-install' does everything correctly.

The attached patch also bumps PORTREVISION for math/lapack (not slave ports) since this will change the package.

QA:
  portlint - ok (no new warnings)
  poudriere - ok (11-stable/amd64)
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-14 10:24:13 UTC
Are there any known user / consumer port impacts of this issue at present, and is this a recent regression/change?

Are you able to run some tests against consumer ports that rely on this library post change as well?
Comment 2 Thierry Thomas freebsd_committer 2021-07-18 15:53:08 UTC
Committed, thanks!
Comment 3 commit-hook freebsd_committer 2021-07-18 15:53:41 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=8af3d45c8b1fbc2ace55eccd74b93defffce5b1a

commit 8af3d45c8b1fbc2ace55eccd74b93defffce5b1a
Author:     Thierry Thomas <thierry@FreeBSD.org>
AuthorDate: 2021-07-18 15:37:07 +0000
Commit:     Thierry Thomas <thierry@FreeBSD.org>
CommitDate: 2021-07-18 15:40:50 +0000

    math/lapack: fix broken lib symlink

    In lapack-3.10.0, there is a broken sym link for libtmglib.so.3.10.0
    (should be a file):

    /usr/local/lib/libtmglib.so.3@ -> libtmglib.so.3.10.0
    /usr/local/lib/libtmglib.so.3.10.0@ -> libtmglib.so.3

    Just remove the unnecessary code in post-install for libtmglib shared
    lib files. 'do-install' does everything correctly.

    PR:             257139
    Reported by:    John Hein <jcfyecrayz (at) liamekaens.com>

 math/lapack/Makefile | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
Comment 4 commit-hook freebsd_committer 2021-07-18 15:58:42 UTC
A commit in branch 2021Q3 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=66f727881fa71278eb1c0941467e43a7579df876

commit 66f727881fa71278eb1c0941467e43a7579df876
Author:     Thierry Thomas <thierry@FreeBSD.org>
AuthorDate: 2021-07-18 15:37:07 +0000
Commit:     Thierry Thomas <thierry@FreeBSD.org>
CommitDate: 2021-07-18 15:57:30 +0000

    math/lapack: fix broken lib symlink

    In lapack-3.10.0, there is a broken sym link for libtmglib.so.3.10.0
    (should be a file):

    /usr/local/lib/libtmglib.so.3@ -> libtmglib.so.3.10.0
    /usr/local/lib/libtmglib.so.3.10.0@ -> libtmglib.so.3

    Just remove the unnecessary code in post-install for libtmglib shared
    lib files. 'do-install' does everything correctly.

    PR:             257139
    Reported by:    John Hein <jcfyecrayz (at) liamekaens.com>

    (cherry picked from commit 8af3d45c8b1fbc2ace55eccd74b93defffce5b1a)

 math/lapack/Makefile | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)