Bug 257142 - misc/shared-mime-info: fails to build, libxml2mod.so: Undefined symbol "xmlPopOutputCallbacks"
Summary: misc/shared-mime-info: fails to build, libxml2mod.so: Undefined symbol "xmlPo...
Status: Closed DUPLICATE of bug 257143
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-12 19:05 UTC by Chris Hutchinson
Modified: 2021-07-13 04:02 UTC (History)
1 user (show)

See Also:


Attachments
build output for misc/shared-mime-info (13.89 KB, text/plain)
2021-07-12 19:05 UTC, Chris Hutchinson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2021-07-12 19:05:39 UTC
Created attachment 226406 [details]
build output for misc/shared-mime-info

ON a stable 12 system and a Python 3.7 default version
I am unable to complete a build of misc/shared-mime-info.
I haven't really investigated the error. But have attached
the complete output of the build in hopes it helps.

Thank you for all your time, and consideration.

--Chris
Comment 1 Chris Hutchinson 2021-07-12 21:12:35 UTC
The failure is caused by Python(37) and required
module (py-libxml2) not updating to the required
version: py-libxml2-2.9.10_3.
I'm not sure who/where to blame to fix this problem.

--Chris
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-13 04:02:39 UTC
Same underlying issue (itstool -> py-libxml2) as bug 257143

*** This bug has been marked as a duplicate of bug 257143 ***