Bug 257219 - devel/py-babel: py38-Babel-2.9.1 conflicts with py37-Babel-2.8
Summary: devel/py-babel: py38-Babel-2.9.1 conflicts with py37-Babel-2.8
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-16 17:09 UTC by Paul Dufresne
Modified: 2021-07-17 03:13 UTC (History)
1 user (show)

See Also:
koobs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Dufresne 2021-07-16 17:09:07 UTC
had tried: portmaster devel/py-babel (14.0-Current)
> ===>  Installing for py38-Babel-2.9.1
> ===>  Checking if py38-Babel is already installed
> ===>   Registering installation for py38-Babel-2.9.1 as automatic
> Installing py38-Babel-2.9.1...
> pkg-static: py38-Babel-2.9.1 conflicts with py37-Babel-2.8.0 (installs files into the same place).  Problematic file: /usr/local/bin/pybabel
> *** Error code 1

I am not very experimented. Unsure it is not something I do wrong.
Comment 1 Li-Wen Hsu freebsd_committer 2021-07-16 17:59:39 UTC
(In reply to Paul Dufresne from comment #0)
It seems that your system has py37-Babel-2.8 installed, and it was installed when python 3.7 is the default version so I guess the two packages both have /usr/local/bin/pybabel and caused the conflict.  I suggest you check the 20210425 entry of the UPDATING file. If you already have done that or cannot do it. Just remove py37-Babel-2.8 can solve this. But you may still encounter similar issues in the future when install other python packages.
Comment 2 Paul Dufresne 2021-07-16 22:13:25 UTC
Ok, applying UPDATING 20210425 entry did indeed fixed it. Thanks!