Bug 257226 - sysutils/kf5-baloo multiple baloo_file processes for a single user
Summary: sysutils/kf5-baloo multiple baloo_file processes for a single user
Status: Closed Not Enough Information
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL: https://www.freshports.org/sysutils/k...
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-07-17 08:18 UTC by Graham Perrin
Modified: 2022-10-23 03:30 UTC (History)
1 user (show)

See Also:
grahamperrin: maintainer-feedback-


Attachments
Example A: screenshot of htop showing two baloo_file processes (272.86 KB, image/png)
2021-07-17 08:18 UTC, Graham Perrin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin freebsd_committer 2021-07-17 08:18:29 UTC
Created attachment 226502 [details]
Example A: screenshot of htop showing two baloo_file processes

The baloo_file process for a user continues to run after the user leaves the destkop environment. 

Subsequent reuse of the DE by the same user results in a concurrent (higher numbered) baloo_file process, under which baloo_file_extractor processes sometimes run. 

Whilst I have never observed a baloo_file_extractor running under the lower numbered baloo_file process in this situation, I assume that it's unnecessary to have two baloo_file processes.
Comment 1 Graham Perrin freebsd_committer 2022-10-23 03:30:20 UTC
Three points: 

1. as far as I can tell, no-one else in a FreeBSD area reported this bug

2. off-topic, I use Recoll <https://www.freshports.org/deskutils/recoll/>, 
   the package for which is capable of real-time indexing since 
   37991a7381a067c2e744e7debafcf18aef664e35 
   <https://github.com/freebsd/freebsd-ports/commit/37991a7381a067c2e744e7debafcf18aef664e35>

   – I no longer attempt use of Baloo

3. no feedback.

It seems reasonable for me to close this report, which I opened. 

If anyone finds a matching report upstream, we might reopen here. Thanks. 

<https://bugs.kde.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=ASSIGNED&bug_status=REOPENED&component=Baloo&component=Baloo+File+Daemon&component=balooctl&list_id=2185115&order=Bug+Number&query_format=advanced>