Bug 257238 - mail/postfixadmin: Update to 3.3.9
Summary: mail/postfixadmin: Update to 3.3.9
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL: https://github.com/postfixadmin/postf...
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2021-07-17 22:56 UTC by Daniel Gerzo
Modified: 2021-07-18 18:25 UTC (History)
1 user (show)

See Also:
ports.maintainer: maintainer-feedback+
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Gerzo freebsd_committer 2021-07-17 22:56:43 UTC
there is a new version, currently 3.3.9
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-18 02:21:26 UTC
^Triage: Substantial number of releases/bugfixes, consider MFH. Among other changelog entries...

  - PostfixAdmin requires PHP 7.0 or greater.
  - MySQL 8 compatibility
  - update bundled smarty library (lib/smarty to 3.1.32; includes security fixes)
  - add token to login.php to prevent CSRF
  - Security improvements (setup.php)
  - Users moving to v3.3.0 will find their existing setup_password will no longer work, and will need regenerating (may require UPDATING notes or pkg-message)
Comment 3 Rin Morningstar 2021-07-18 18:25:09 UTC
There have been multiple impediments to getting this done, but it is in progress.