Bug 257239 - multimedia/mpv: Multiple patches (commits) fail to fetch: github.com/mpv-player/mpv/commit/*.patch: size mismatch
Summary: multimedia/mpv: Multiple patches (commits) fail to fetch: github.com/mpv-play...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-multimedia (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-07-17 23:50 UTC by Oleh Vinichenko
Modified: 2021-07-20 15:02 UTC (History)
0 users

See Also:
jbeich: merge-quarterly+


Attachments
poudriere build.log (17.24 KB, text/plain)
2021-07-17 23:50 UTC, Oleh Vinichenko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleh Vinichenko 2021-07-17 23:50:10 UTC
Created attachment 226522 [details]
poudriere build.log

poudriere build of multimedia/mpv failing due to patch size mismatch.
This is also reproduced by make clean fetch by ports system
Comment 1 commit-hook freebsd_committer 2021-07-20 14:56:19 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=79fa908f4a183b8e3e537cac48d5f70e859c44ec

commit 79fa908f4a183b8e3e537cac48d5f70e859c44ec
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-07-20 14:47:02 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-07-20 14:54:49 +0000

    multimedia/mpv: unbreak fetch due to repo growth

    $ make checksum TRYBROKEN= MASTER_SITE_BACKUP= DISTDIR=$(mktemp -dt distfiles)
    [...]
    => 1bb2665e3d09.patch doesn't seem to exist in /tmp/distfiles.iVgzzfBs/.
    => Attempting to fetch https://github.com/mpv-player/mpv/commit/1bb2665e3d09.patch
    fetch: https://github.com/mpv-player/mpv/commit/1bb2665e3d09.patch: size mismatch: expected 2337, actual 2341
    => Couldn't fetch it - please try to retrieve this
    => port manually into /tmp/distfiles.iVgzzfBs/ and try again.
    *** Error code 1

    -index 833fbddb1b..4a1ffd4579 100644
    +index 833fbddb1bd..4a1ffd45798 100644
    -index 8318c5190c..a1fb04bd59 100644
    +index 8318c5190c5..a1fb04bd592 100644
    -index 4a1ffd4579..2802ce914c 100644
    +index 4a1ffd45798..2802ce914ca 100644
    -index a1fb04bd59..dff20f716d 100644
    +index a1fb04bd592..dff20f716d6 100644
    -index 2802ce914c..265787e73a 100644
    +index 2802ce914ca..265787e73a9 100644
    -index dff20f716d..df0c05e139 100644
    +index dff20f716d6..df0c05e139e 100644
    -index df0c05e139..3365daa48a 100644
    +index df0c05e139e..3365daa48a5 100644
    -index 3365daa48a..46c289dafe 100644
    +index 3365daa48a5..46c289dafe3 100644
    -index 46c289dafe..f4ba8db7c7 100644
    +index 46c289dafe3..f4ba8db7c7c 100644
    -index d70286647f..1c0b9e146b 100644
    +index d70286647fc..1c0b9e146be 100644
    -index 52a38b63be..7c347cb138 100644
    +index 52a38b63be2..7c347cb1380 100644
    -index 0000000000..11b182e52d
    +index 00000000000..11b182e52d9
    -index 0ced76244a..e9f4d53002 100644
    +index 0ced76244a0..e9f4d53002c 100644
    -index 14c254e1ec..a12cbf19e1 100644
    +index 14c254e1ec9..a12cbf19e17 100644
    -index 706c952604..5545b3378d 100644
    +index 706c9526046..5545b3378d5 100644
    -index f8df590511..8244acff26 100644
    +index f8df590511d..8244acff261 100644

    PR:             257239
    Reported by:    Oleh Vinichenko

 multimedia/mpv/distinfo | 36 ++++++++++++++++++------------------
 1 file changed, 18 insertions(+), 18 deletions(-)
Comment 2 commit-hook freebsd_committer 2021-07-20 14:56:20 UTC
A commit in branch 2021Q3 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=2d63a80a43f643f344dfdf8d14899b83cdf937b2

commit 2d63a80a43f643f344dfdf8d14899b83cdf937b2
Author:     Jan Beich <jbeich@FreeBSD.org>
AuthorDate: 2021-07-20 14:47:02 +0000
Commit:     Jan Beich <jbeich@FreeBSD.org>
CommitDate: 2021-07-20 14:55:30 +0000

    multimedia/mpv: unbreak fetch due to repo growth

    $ make checksum TRYBROKEN= MASTER_SITE_BACKUP= DISTDIR=$(mktemp -dt distfiles)
    [...]
    => 1bb2665e3d09.patch doesn't seem to exist in /tmp/distfiles.iVgzzfBs/.
    => Attempting to fetch https://github.com/mpv-player/mpv/commit/1bb2665e3d09.patch
    fetch: https://github.com/mpv-player/mpv/commit/1bb2665e3d09.patch: size mismatch: expected 2337, actual 2341
    => Couldn't fetch it - please try to retrieve this
    => port manually into /tmp/distfiles.iVgzzfBs/ and try again.
    *** Error code 1

    -index 833fbddb1b..4a1ffd4579 100644
    +index 833fbddb1bd..4a1ffd45798 100644
    -index 8318c5190c..a1fb04bd59 100644
    +index 8318c5190c5..a1fb04bd592 100644
    -index 4a1ffd4579..2802ce914c 100644
    +index 4a1ffd45798..2802ce914ca 100644
    -index a1fb04bd59..dff20f716d 100644
    +index a1fb04bd592..dff20f716d6 100644
    -index 2802ce914c..265787e73a 100644
    +index 2802ce914ca..265787e73a9 100644
    -index dff20f716d..df0c05e139 100644
    +index dff20f716d6..df0c05e139e 100644
    -index df0c05e139..3365daa48a 100644
    +index df0c05e139e..3365daa48a5 100644
    -index 3365daa48a..46c289dafe 100644
    +index 3365daa48a5..46c289dafe3 100644
    -index 46c289dafe..f4ba8db7c7 100644
    +index 46c289dafe3..f4ba8db7c7c 100644
    -index d70286647f..1c0b9e146b 100644
    +index d70286647fc..1c0b9e146be 100644
    -index 52a38b63be..7c347cb138 100644
    +index 52a38b63be2..7c347cb1380 100644
    -index 0000000000..11b182e52d
    +index 00000000000..11b182e52d9
    -index 0ced76244a..e9f4d53002 100644
    +index 0ced76244a0..e9f4d53002c 100644
    -index 14c254e1ec..a12cbf19e1 100644
    +index 14c254e1ec9..a12cbf19e17 100644
    -index 706c952604..5545b3378d 100644
    +index 706c9526046..5545b3378d5 100644
    -index f8df590511..8244acff26 100644
    +index f8df590511d..8244acff261 100644

    PR:             257239
    Reported by:    Oleh Vinichenko

    (cherry picked from commit 79fa908f4a183b8e3e537cac48d5f70e859c44ec)

 multimedia/mpv/distinfo | 36 ++++++++++++++++++------------------
 1 file changed, 18 insertions(+), 18 deletions(-)
Comment 3 Jan Beich freebsd_committer 2021-07-20 15:02:14 UTC
Thanks for reporting. git-format-patch(1) doesn't enable --full-index by default, making patches slightly change due to repo size where forks GitHub contribute to such growth.