Bug 257242 - x11-themes/kde-icons-black-and-white update package message
Summary: x11-themes/kde-icons-black-and-white update package message
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Fernando Apesteguía
URL: https://cgit.freebsd.org/ports/tree/x...
Keywords: easy
: 257064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-18 06:57 UTC by Graham Perrin
Modified: 2022-12-16 16:27 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (portmaster)


Attachments
Screenshot: System Settings (394.77 KB, image/png)
2021-07-18 06:57 UTC, Graham Perrin
no flags Details
git diff for x11-themes/kde-icons-black-and-white (1.98 KB, patch)
2021-07-29 21:46 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin freebsd_committer 2021-07-18 06:57:51 UTC
Created attachment 226525 [details]
Screenshot: System Settings

The phrases 'Control Center' and 'Look and Feel' are no longer used. 

Instead: 'System Settings' and 'Appearance'.
Comment 1 Graham Perrin freebsd_committer 2021-07-18 06:59:10 UTC
<https://www.freshports.org/x11-themes/kde-icons-black-and-white/#message>

pkg query %M kde-icons-black-and-white
Comment 2 Chris Hutchinson 2021-07-20 16:08:31 UTC
Thanks for the heads up, Graham.
I already have a pr(1) open for this port.
I'll make the necessary modifications, and add
them to that one, and close this when they're
committed.

Thanks again! :-)

--Chris
Comment 3 Chris Hutchinson 2021-07-29 21:46:00 UTC
Created attachment 226786 [details]
git diff for x11-themes/kde-icons-black-and-white

This patch addresses the problem reported here, as well
as the problem reported in bug #257064. "Killing
2 birds with one stone". I'll close the other bug as
a duplicate of this one.

Changes
Makefile -- removes "Created by",
replaces flakey MASTER_SITES.
Renames distfile.

distinfo -- updates to current standards && uses current distfile name

pkg-message -- replaces "Control Center" and "Look and Feel"
with "System Settings" and "Appearance"

That's it.

Thanks!

--Chris
Comment 4 Chris Hutchinson 2021-07-29 21:49:40 UTC
*** Bug 257064 has been marked as a duplicate of this bug. ***
Comment 5 Nuno Teixeira freebsd_committer 2021-08-01 15:14:13 UTC
(In reply to Chris Hutchinson from comment #3)

Why did you removed: "# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>"?

For what I know this should only be removed when port "creator" decides it so.
Comment 6 Chris Hutchinson 2021-09-09 21:20:17 UTC
(In reply to Nuno Teixeira from comment #5)
The
# Created by:
entry has been depreciated for about a year now.
Given I was making a change to the Makefile; I took
the opportunity to remove it. As they are no longer
used. So hold no value.

--Chris
Comment 7 Guangyuan Yang freebsd_committer 2021-09-09 23:26:41 UTC
(In reply to Chris Hutchinson from comment #6)

My understanding is that it is now discouraged to add "# Created by" line for new ports, but an existing line should not be removed.
Comment 8 Chris Hutchinson 2021-09-10 06:15:03 UTC
(In reply to Guangyuan Yang from comment #7)
Do you know why that is?
I understand depreciating something doesn't mean its
immediate removal. Because doing so might affect the
guaranteed stability of a currently supported version.
But in this case, I can't understand how after a year,
it shouldn't be removed, given it has zero affect on
the the port itself.
Mind you; I am not trying to argue the point. Just
trying to understand. :-)

Thanks for taking the time to respond.

--Chris
Comment 9 Chris Hutchinson 2022-12-05 21:23:59 UTC
See also: bug #268177
Comment 10 commit-hook freebsd_committer 2022-12-16 16:24:59 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=743aad0dbc35150bd939db52301c929f6bb711c8

commit 743aad0dbc35150bd939db52301c929f6bb711c8
Author:     Chris Hutchinson <portmaster@bsdforge.com>
AuthorDate: 2022-12-16 06:47:07 +0000
Commit:     Fernando Apesteguía <fernape@FreeBSD.org>
CommitDate: 2022-12-16 16:20:27 +0000

    x11-themes/kde-icons-black-and-white: Fix fetch

    Unbreak port and update pkg-message file.

    PR:             257242 268177
    Reported by:    portmaster@bsdforge.com (maintainer)
    MFH:            2022Q4 (quarterly is also broken)

 x11-themes/kde-icons-black-and-white/Makefile    | 6 ++----
 x11-themes/kde-icons-black-and-white/distinfo    | 5 +++--
 x11-themes/kde-icons-black-and-white/pkg-message | 4 ++--
 3 files changed, 7 insertions(+), 8 deletions(-)
Comment 11 commit-hook freebsd_committer 2022-12-16 16:27:01 UTC
A commit in branch 2022Q4 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=f3b5f5fc0afecb2d2627841932db39c1b2193b45

commit f3b5f5fc0afecb2d2627841932db39c1b2193b45
Author:     Chris Hutchinson <portmaster@bsdforge.com>
AuthorDate: 2022-12-16 06:47:07 +0000
Commit:     Fernando Apesteguía <fernape@FreeBSD.org>
CommitDate: 2022-12-16 16:22:01 +0000

    x11-themes/kde-icons-black-and-white: Fix fetch

    Unbreak port and update pkg-message file.

    PR:             257242 268177
    Reported by:    portmaster@bsdforge.com (maintainer)
    MFH:            2022Q4 (quarterly is also broken)

    (cherry picked from commit 743aad0dbc35150bd939db52301c929f6bb711c8)

 x11-themes/kde-icons-black-and-white/Makefile    | 4 ++--
 x11-themes/kde-icons-black-and-white/distinfo    | 5 +++--
 x11-themes/kde-icons-black-and-white/pkg-message | 4 ++--
 3 files changed, 7 insertions(+), 6 deletions(-)
Comment 12 Fernando Apesteguía freebsd_committer 2022-12-16 16:27:11 UTC
Done in bug #268177