Bug 257258 - net-mgmt/netdata: Patches (upstream commits) fail to fetch: Filesize/Checksum broken
Summary: net-mgmt/netdata: Patches (upstream commits) fail to fetch: Filesize/Checksum...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Kevin Bowling
URL:
Keywords: easy
Depends on:
Blocks:
 
Reported: 2021-07-18 20:24 UTC by leeb
Modified: 2021-07-21 16:33 UTC (History)
2 users (show)

See Also:
kbowling: maintainer-feedback? (leeb)
kbowling: merge-quarterly-


Attachments
patch (1.13 KB, text/plain)
2021-07-18 20:24 UTC, leeb
koobs: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description leeb 2021-07-18 20:24:50 UTC
Created attachment 226538 [details]
patch

Filesize/Checksum broken
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-19 03:55:42 UTC
Comment on attachment 226538 [details]
patch

Pending QA, this change is:

Approved by: portmgr (blanket: unmaintained port, build fix)
MFH: 2020Q3 (blanket: build fix)
Comment 2 Kevin Bowling freebsd_committer 2021-07-20 19:02:22 UTC
(In reply to leeb from comment #0)
Your patch does not apply cleanly (line break on L16, DOS line endings?).  Additionally 'make makesum' seems to report the existing hashes.  Maybe a transient issue with GitHub?

% make makesum

===>   netdata-1.31.0_1 depends on file: /usr/local/sbin/pkg - found
=> netdata-v1.31.0.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://github.com/netdata/netdata/releases/download/v1.31.0/netdata-v1.31.0.tar.gz
netdata-v1.31.0.tar.gz                                  11 MB 2866 kBps    04s
=> fd15080f65fde1c484a06cbc5a13a2853639a960.patch doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://github.com/forkbomb9/netdata/commit/fd15080f65fde1c484a06cbc5a13a2853639a960.patch
fd15080f65fde1c484a06cbc5a13a2853639a960.patch          30 MB 2545 kBps    13s
=> 4b130034f223a5034c241b8a3e905d8f8031747d.patch doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://github.com/netdata/netdata/commit/4b130034f223a5034c241b8a3e905d8f8031747d.patch
4b130034f223a5034c241b8a3e905d8f8031747d.patch        5207  B 4298 kBps    00s
===> Fetching all distfiles required by netdata-1.31.0_1 for building
kev-ws-aurora% git diff
diff --git a/net-mgmt/netdata/distinfo b/net-mgmt/netdata/distinfo
index 69a5b9102890..086f96bd4e43 100644
--- a/net-mgmt/netdata/distinfo
+++ b/net-mgmt/netdata/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1621898113
+TIMESTAMP = 1626807515
 SHA256 (netdata-v1.31.0.tar.gz) = ca68f725224e8bbec041b493891376fbf41aedb47c4ac06161c2eda990089c9f
 SIZE (netdata-v1.31.0.tar.gz) = 12528280
-SHA256 (4b130034f223a5034c241b8a3e905d8f8031747d.patch) = 9a5be823ba673d2490ec7140cc3726569253e5114157c730d7533916194720d7
-SIZE (4b130034f223a5034c241b8a3e905d8f8031747d.patch) = 5207
 SHA256 (fd15080f65fde1c484a06cbc5a13a2853639a960.patch) = b1ed548a1f41984f40d36162dc2325e54381d829210d117dfcba3521e2b9c7ea
 SIZE (fd15080f65fde1c484a06cbc5a13a2853639a960.patch) = 32024618
+SHA256 (4b130034f223a5034c241b8a3e905d8f8031747d.patch) = 9a5be823ba673d2490ec7140cc3726569253e5114157c730d7533916194720d7
+SIZE (4b130034f223a5034c241b8a3e905d8f8031747d.patch) = 5207
Comment 3 leeb 2021-07-21 16:33:57 UTC
No clue why the diff was garbage, you can see how I produced it, maybe that was the wrong use of git?  I don't use DOS or Windows.

This morning it works for me too.
Sorry for the noise, next time github barfs I'll just wait a couple of days before trying again.