Bug 257293 - 13.0-RELEASE crashes at boot on Haswell
Summary: 13.0-RELEASE crashes at boot on Haswell
Status: Closed DUPLICATE of bug 254373
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 13.0-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords: crash, needs-qa, regression
Depends on:
Blocks:
 
Reported: 2021-07-20 04:15 UTC by unitrunker
Modified: 2021-07-23 22:40 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description unitrunker 2021-07-20 04:15:21 UTC
Kernel panic during boot.
Thinkpad T440p with Haswell i5-4340m.
Worked fine in 12.1-RELEASE & 12.2-REKEASE.

Screenshot of panic to follow.
Comment 1 unitrunker 2021-07-20 21:17:22 UTC
panic: vm_fault_lookup: fault on nofault entry, addr: 0xffffffe090b035000
cpuid = 3
time = 1
KDB: stack backtrace:
#0  0xffffffff80c57515 at kdb_backtrace+0x65
#1  0xffffffff80c09ef1 at vpanic+0x181
#2  0xffffffff80c09d63 at panic+0x43
#3  0xffffffff80f289db at vm_fault+0x144b
#4  0xffffffff80f274b1 at vm_fault_trap+0xb1
#5  0xffffffff8108b3b8 at trap_pfault+0x1f8
#6  0xffffffff8108a86d at trap+0x27d
#7  0xffffffff810619a8 at calltrap+0x8
#8  0xffffffff80c421c1 at boot_run_interrupt_driver_config_hooks+0x21
#9  0xffffffff80b9a18f at mi_startup+0xdf
#10 0xffffffff8037c082 at btext+0x2c
Comment 2 unitrunker 2021-07-20 21:19:18 UTC
First line should read:
panic: vm_fault_lookup: fault on nofault entry, addr: 0xffffffe0090b035000
Comment 3 unitrunker 2021-07-20 21:41:35 UTC
I have a poor work-around (but better than nothing).
Disconnect AC power and reboot.
On the third try - without AC power - the boot usually completes.
Everything seems to work once I get past this stage.

The CPU defaults 2.9 Ghz when booted on AC power and 0.8 Ghz when booting from battery power.

So far I've not gotten a crash dump. I do have a swap partition and dumpon(8) verifies this. rc.conf has dumpdev="AUTO"
Comment 4 unitrunker 2021-07-20 21:50:21 UTC
# uname -a
FreeBSD hostname 13.0-RELEASE-p3 FreeBSD 13.0-RELEASE-p3 #0: Tue Jun 29 19:46:20 UTC 2021      root@amd64-builder.daemonology.net:/usr/obj/usr/src/amd64.amd64/sys/GENERIC  amd64
Comment 5 Yang Zhong 2021-07-21 19:43:25 UTC
Here is a patch that should fix this problem: https://reviews.freebsd.org/D31262
Comment 6 unitrunker 2021-07-23 00:34:07 UTC
That works! Thank you.
Comment 7 Mark Johnston freebsd_committer 2021-07-23 22:40:32 UTC

*** This bug has been marked as a duplicate of bug 254373 ***