Bug 257354 - sysutils/lsof build failure on 12.2-STABLE (too few arguments to kern_unlinkat())
Summary: sysutils/lsof build failure on 12.2-STABLE (too few arguments to kern_unlinka...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Larry Rosenman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-23 13:26 UTC by Bertrand Petit
Modified: 2021-07-23 16:52 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ler)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bertrand Petit 2021-07-23 13:26:55 UTC
The lsof port (version 4.94.0 epoch 8) fails to build on an arm/armv7 12.2-STABLE host (rev 8b9b3d90de5dbeba0f8d68a154c657c0c139e5a9).

--- dnode2.o ---
In file included from dnode2.c:61:
In file included from /usr/src/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/sys/zfs_znode.h:33:
In file included from /usr/src/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/sys/dmu.h:47:
In file included from /usr/src/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/sys/zfs_context.h:73:
In file included from /usr/src/sys/cddl/compat/opensolaris/sys/vfs.h:37:
/usr/src/sys/cddl/compat/opensolaris/sys/vnode.h:243:10: warning: implicit declaration of function 'VOP_FSYNC' is invalid in C99 [-Wimplicit-function-declaration]
        error = VOP_FSYNC(vp, MNT_WAIT, curthread);
                ^
/usr/src/sys/cddl/compat/opensolaris/sys/vnode.h:281:59: error: too few arguments to function call, expected 6, have 5
        return (kern_unlinkat(curthread, AT_FDCWD, fnamep, seg, 0));
                ~~~~~~~~~~~~~                                    ^
/usr/include/sys/syscallsubr.h:304:1: note: 'kern_unlinkat' declared here
int     kern_unlinkat(struct thread *td, int fd, char *path,
^
Comment 1 Bertrand Petit 2021-07-23 16:52:16 UTC
This is not a bug but an oversight on my part: I forgot to update /usr/src to match userland.