Created attachment 226646 [details]
* portlint: OK (looks fine.)
* testport: OK (poudriere: 13.0, amd64 tested)
Great job Goran. Review items:
All *_DEPENDS need to match upstream version specs , in this case including the max versions, unless they are patched (patched deps must be tested/confirmed to work with test suites)
Painful, but necessary. Please encourage upstreams to distribute (sdist) dependencies of the form >=, so they can develop against, test and fix issues with later versions as early as possible (ideally before users do and are impacted)
requires = [
"typing-extensions >=22.214.171.124; python_version < '3.8'",
sqlalchemy = [
mongodb = [
tortoise-orm = [
ormar = [
oauth = [
How do I specify min and max? I tried with this:
(In reply to Goran Mekić from comment #2)
As far as I know both >x,<y and x<y 'work', but there 'may' (still?) be caveats with the first (comma) one, even though its the better syntax.
What symptoms do you see with the former?
Created attachment 226710 [details]
It works now. No idea what was wrong but I probably made some typo (or I should blame LSD in the water pipes :o). Anyway, here's the revised patch.
Created attachment 226713 [details]
Added transient dependency and figured out what was wrong with min,max versions. Max can only have <max, not <=max.
Created attachment 226715 [details]
Added optional and transitional dependencies.
Python doesn't need to block / be assignee on new ports
Not sure why i merge-quarterly'd (?) this