Bug 257373 - Problem on nasm? ld? open syscall? My assembly code?
Summary: Problem on nasm? ld? open syscall? My assembly code?
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 13.0-STABLE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-24 01:57 UTC by mazoti
Modified: 2021-07-24 08:12 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mazoti 2021-07-24 01:57:37 UTC
Hi!

I did an assembly project using nasm and ld on various OSs and archs.
The project worked on all of them but it has problems on FREEBSD 13 - x64.
On FreeBSD 13 - x86 also worked, but on x64 it's not opening the file passed in command line parameter.

The sources could be found at:
https://github.com/mazoti/adler32/tree/main/unix-x64

(to see other sources check the root)

The binaries could be found at:
https://github.com/mazoti/adler32/blob/main/releases/

Using the code inside a C program also worked.
I still don't know if the problem is in my code, on nasm, ld or open syscall.


Thanks for you time!
Comment 1 Andriy Gapon freebsd_committer 2021-07-24 08:12:31 UTC
Please use FreeBSD mailing lists, forums, IRC, etc to discuss issues like that.
I think that, for instance, hackers@FreeBSD.org is a good candidate.