Bug 257375 - net/openldap24-client: organizations needing LDAP SASL support cannot use pre-built packages
Summary: net/openldap24-client: organizations needing LDAP SASL support cannot use pre...
Status: Closed DUPLICATE of bug 257374
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-24 04:52 UTC by David E. O'Brien
Modified: 2021-07-24 05:04 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (delphij)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David E. O'Brien freebsd_committer 2021-07-24 04:52:23 UTC
As an example, Juniper Networks needs openldap-sasl-client in order to authenticate on our FreeBSD build systems.  But openldap-client is a dependacy for a LARGE number of other ports we need to use.


The 'ldd' difference that SASL support adds is only:
 /usr/local/bin/ldapsearch:
 	libldap-2.4.so.2 => /usr/local/lib/libldap-2.4.so.2
 	liblber-2.4.so.2 => /usr/local/lib/liblber-2.4.so.2
+	libsasl2.so.3 => /usr/local/lib/libsasl2.so.3
 	libssl.so.111 => /usr/lib/libssl.so.111
 	libcrypto.so.111 => /lib/libcrypto.so.111
 	libc.so.7 => /lib/libc.so.7
+	libdl.so.1 => /usr/lib/libdl.so.1
 	libthr.so.3 => /lib/libthr.so.3

I do not see this as a burden given the LARGE number of dependancies most of our other ports have grown in the last decade as every knob of functionality seems turned on in many.

SASL support should be the default for openldap-client given it is so low cost, but the cost of having to build 1000 packages from source is a high burden on an organization.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-24 05:03:44 UTC

*** This bug has been marked as a duplicate of bug 257374 ***