Bug 257383 - net-im/telegram-desktop: pulseaudio as a requirement
Summary: net-im/telegram-desktop: pulseaudio as a requirement
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-24 14:26 UTC by Daniel Menelkir
Modified: 2021-07-25 01:27 UTC (History)
1 user (show)

See Also:
henry.hu.sh: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Menelkir 2021-07-24 14:26:44 UTC
Pulseaudio is stated as a requirement even when you have it unchecked to use ALSA.
Comment 1 Henry Hu 2021-07-24 16:27:12 UTC
Do you mean it is stated as a build dependency, or a lib dependency?
As a build dependency, it's always needed, even if you don't select it.
As a lib dependency, it's only needed if you select PULSEAUDIO option.

In other words, if you don't choose the option, you can delete pulseaudio after building it.
Comment 2 Daniel Menelkir 2021-07-24 20:03:50 UTC
(In reply to Henry Hu from comment #1)
Yeah, I've got it after building. 
Another question, it's ok that telegram-desktop binary is static linked to libpipewire even so I'm using alsa in the options?
Comment 3 Henry Hu 2021-07-24 20:57:47 UTC
(In reply to Daniel Menelkir from comment #2)
well, they mentioned they use pipewire for screenshots... so likely it's always needed. see https://github.com/desktop-app/tg_owt/blob/91d836dc84a16584c6ac52b36c04c0de504d9c34/CMakeLists.txt#L25
Comment 4 Daniel Menelkir 2021-07-24 20:59:32 UTC
(In reply to Henry Hu from comment #3)
I see. I was quite confused by the process of the things (since it needs both for different reasons). I'll close this, thanks for your time.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-25 01:27:00 UTC
^Triage: Correct resolution, FIXED is for "resolved with a change" (like a commit)