Bug 257407 - Cross compiling fails on kernel compilation on different stages
Summary: Cross compiling fails on kernel compilation on different stages
Status: Closed DUPLICATE of bug 257132
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: i386 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-25 10:42 UTC by misho
Modified: 2021-07-26 06:53 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description misho 2021-07-25 10:42:15 UTC
When I try to cross-compile i386 and amd64 architecture under amd64 build host.
If I have a good chance to finish kernel compiling and linking then process fails on compiling of kernel modules.

From last update of CURRENT sources. Now I have different issue with compile procedure of kernel.

cc -target i386-unknown-freebsd14.0 --sysroot=/usr/home/m/work/elwix/build/2.8_x86/obj/i386/usr/home/m/work/freebsd.src/i386.i386/tmp -B/usr/home/m/work/elwix/build/2.8_x86/obj/i386/usr/home/m/work/freebsd.src/i386.i386/tmp/usr/bin -c -O2 -pipe  -fno-strict-aliasing  -g -nostdinc  -I. -I/usr/home/m/work/freebsd.src/sys -I/usr/home/m/work/freebsd.src/sys/contrib/ck/include -I/usr/home/m/work/freebsd.src/sys/contrib/libfdt -D_KERNEL -DHAVE_KERNEL_OPTION_HEADERS -include opt_global.h -fno-common    -MD  -MF.depend.subr_prng.o -MTsubr_prng.o -fdebug-prefix-map=./machine=/usr/home/m/work/freebsd.src/sys/i386/include -fdebug-prefix-map=./x86=/usr/home/m/work/freebsd.src/sys/x86/include -mno-mmx -mno-sse -msoft-float -ffreestanding -fwrapv -fstack-protector -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wcast-qual -Wundef -Wno-pointer-sign -D__printf__=__freebsd_kprintf__ -Wmissing-include-dirs -fdiagnostics-show-option -Wno-unknown-pragmas -Wno-error=tautological-compare -Wno-error=empty-body -Wno-error=parentheses-equality -Wno-error=unused-function -Wno-error=pointer-sign -Wno-error=shift-negative-value -Wno-address-of-packed-member -Wno-format-zero-length   -mno-aes -mno-avx  -std=iso9899:1999 -Werror /usr/home/m/work/freebsd.src/sys/kern/subr_prng.c
Assertion failed: ((EltVT.getSizeInBits() >= 64 || (uint64_t)((int64_t)Val >> EltVT.getSizeInBits()) + 1 < 2) && "getConstant with a uint64_t value that doesn't fit in the type!"), function getConstant, file /usr/src/contrib/llvm-project/llvm/lib/CodeGen/SelectionDAG/SelectionDAG.cpp, line 1337.
PLEASE submit a bug report to https://bugs.freebsd.org/submit/ and include the crash backtrace, preprocessed source, and associated run script.
Stack dump:
0.	Program arguments: cc -target i386-unknown-freebsd14.0 --sysroot=/usr/home/m/work/elwix/build/2.8_x86/obj/i386/usr/home/m/work/freebsd.src/i386.i386/tmp -B/usr/home/m/work/elwix/build/2.8_x86/obj/i386/usr/home/m/work/freebsd.src/i386.i386/tmp/usr/bin -c -O2 -pipe -fno-strict-aliasing -g -nostdinc -I. -I/usr/home/m/work/freebsd.src/sys -I/usr/home/m/work/freebsd.src/sys/contrib/ck/include -I/usr/home/m/work/freebsd.src/sys/contrib/libfdt -D_KERNEL -DHAVE_KERNEL_OPTION_HEADERS -include opt_global.h -fno-common -MD -MF.depend.subr_prng.o -MTsubr_prng.o -fdebug-prefix-map=./machine=/usr/home/m/work/freebsd.src/sys/i386/include -fdebug-prefix-map=./x86=/usr/home/m/work/freebsd.src/sys/x86/include -mno-mmx -mno-sse -msoft-float -ffreestanding -fwrapv -fstack-protector -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wcast-qual -Wundef -Wno-pointer-sign -D__printf__=__freebsd_kprintf__ -Wmissing-include-dirs -fdiagnostics-show-option -Wno-unknown-pragmas -Wno-error=tautological-compare -Wno-error=empty-body -Wno-error=parentheses-equality -Wno-error=unused-function -Wno-error=pointer-sign -Wno-error=shift-negative-value -Wno-address-of-packed-member -Wno-format-zero-length -mno-aes -mno-avx -std=iso9899:1999 -Werror /usr/home/m/work/freebsd.src/sys/kern/subr_prng.c
1.	<eof> parser at end of file
2.	Code generation
3.	Running pass 'Function Pass Manager' on module '/usr/home/m/work/freebsd.src/sys/kern/subr_prng.c'.
4.	Running pass 'X86 DAG->DAG Instruction Selection' on function '@prng32'
#0 0x0000000004716471 PrintStackTrace /usr/src/contrib/llvm-project/llvm/lib/Support/Unix/Signals.inc:565:13
#1 0x0000000004714645 RunSignalHandlers /usr/src/contrib/llvm-project/llvm/lib/Support/Signals.cpp:72:18
#2 0x00000000046ae23e HandleCrash /usr/src/contrib/llvm-project/llvm/lib/Support/CrashRecoveryContext.cpp:75:5
#3 0x00000000046ae3c3 CrashRecoverySignalHandler /usr/src/contrib/llvm-project/llvm/lib/Support/CrashRecoveryContext.cpp:0:51
#4 0x0000000805cf3dc0 handle_signal /usr/src/lib/libthr/thread/thr_sig.c:0:3
cc: error: clang frontend command failed with exit code 134 (use -v to see invocation)
FreeBSD clang version 12.0.1 (git@github.com:llvm/llvm-project.git llvmorg-12.0.1-rc2-0-ge7dac564cd0e)
Target: i386-unknown-freebsd14.0
Thread model: posix
InstalledDir: /usr/bin
cc: note: diagnostic msg: 
********************

PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
Preprocessed source(s) and associated run script(s) are located at:
cc: note: diagnostic msg: /tmp/subr_prng-3bfc0b.c
cc: note: diagnostic msg: /tmp/subr_prng-3bfc0b.sh
cc: note: diagnostic msg: 

********************
*** Error code 134
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2021-07-26 06:30:33 UTC
^Triage: the crash is in llvm, so Cc: the toolchain ML.
Comment 2 Dimitry Andric freebsd_committer 2021-07-26 06:53:14 UTC

*** This bug has been marked as a duplicate of bug 257132 ***