Bug 257410 - textproc/py-rstfmt: Doesn't work with newer Sphinx
Summary: textproc/py-rstfmt: Doesn't work with newer Sphinx
Status: In Progress
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Danilo G. Baio
URL: https://github.com/dzhu/rstfmt/issues/12
Keywords:
Depends on:
Blocks: 257116
  Show dependency treegraph
 
Reported: 2021-07-25 12:32 UTC by Danilo G. Baio
Modified: 2021-07-26 11:05 UTC (History)
0 users

See Also:
0mp: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Danilo G. Baio freebsd_committer 2021-07-25 12:32:14 UTC
This blocks the Sphinx upgrade.

===>   py38-rstfmt-0.0.9 depends on package: py38-sphinx>=2.4.0,1<4.0,1 - not found
*** Error code 1

Same issue as reported on Github.
Comment 1 Mateusz Piotrowski freebsd_committer 2021-07-26 10:24:14 UTC
Let's not block Sphinx upgrade due to this port. Once the new Sphinx version lands in the tree, we should mark this port as BROKEN.

Perhaps upstream is going to provide a fix for it in the meantime.

I'll keep the bug report open so that we remember to mark the port as BROKEN once new Sphinx hits the tree.

Thanks for the report!
Comment 2 Danilo G. Baio freebsd_committer 2021-07-26 10:58:16 UTC
(In reply to Mateusz Piotrowski from comment #1)

Thanks Mateusz.

I can add the BROKEN parameter within the Sphinx upgrade.
Comment 3 Mateusz Piotrowski freebsd_committer 2021-07-26 11:05:12 UTC
Thank you Danilo!