Bug 257417 - x11-servers/xorg-server: libxaa.so is missing, breaking support for older video hardware
Summary: x11-servers/xorg-server: libxaa.so is missing, breaking support for older vid...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-25 18:33 UTC by Stefan B.
Modified: 2021-07-26 08:18 UTC (History)
2 users (show)

See Also:
jbeich: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan B. 2021-07-25 18:33:27 UTC
For some reason, the libxaa.so library is missing in the xorg-server package.

This breaks some older video card drivers.
The s3 driver is an example.
It does not support the AccelMethod option, instead seems to be hard-coded to use the XAA method.

The libxaa.so driver must have been removed from the xorg-server package some time since 2014, as you can see in this post: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=195810#c3

Could the libxaa.so driver please be put back into the xorg-server package?
Comment 1 Niclas Zeising freebsd_committer 2021-07-26 08:18:34 UTC
XAA was removed upstream in 2012, see the git commit upstream here: https://gitlab.freedesktop.org/xorg/xserver/-/commit/e191e296e6e7861978ea4a0ae9aa7b780e52732b

There is not much we can do, as it is not part of the distribution any more.

If you have an issue with a specific driver, please check if there's a fix upstream that can be imported, and create a new PR for that driver.
Thanks!