Bug 257462 - graphics/mesa-dri: iris is disabled by default since 21.1.5 update
Summary: graphics/mesa-dri: iris is disabled by default since 21.1.5 update
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords: needs-patch, regression
Depends on:
Blocks: 250307
  Show dependency treegraph
 
Reported: 2021-07-27 21:07 UTC by Jan Beich
Modified: 2021-08-04 10:24 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2021-07-27 21:07:34 UTC
After ports 22a85734ff71 OpenGL renderer in yuzu-qt5 stopped working because i965 is stuck with incomplete support for newer extensions. For example, in glxinfo output OpenGL 4.6 -> 3.0 and DRI (classic) give away i965.

$ glxinfo
[...]
 Extended renderer info (GLX_MESA_query_renderer):
-    Vendor: Intel (0x8086)
-    Device: Mesa Intel(R) HD Graphics 530 (SKL GT2) (0x1912)
-    Version: 20.2.3
+    Vendor: Intel Open Source Technology Center (0x8086)
+    Device: Mesa DRI Intel(R) HD Graphics 530 (SKL GT2) (0x1912)
+    Version: 21.1.5
     Accelerated: yes
     Video memory: 3072MB
     Unified memory: yes
     Preferred profile: core (0x1)
     Max core profile version: 4.6
-    Max compat profile version: 4.6
+    Max compat profile version: 3.0
     Max GLES1 profile version: 1.1
     Max GLES[23] profile version: 3.2
-OpenGL vendor string: Intel
-OpenGL renderer string: Mesa Intel(R) HD Graphics 530 (SKL GT2)
-OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.2.3
+OpenGL vendor string: Intel Open Source Technology Center
+OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (SKL GT2)
+OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.1.5
[...]
Comment 1 Jan Beich freebsd_committer 2021-07-27 21:19:51 UTC
How x11@ team does QA? Each mesa* update brings tons of regressions.
Comment 2 Jan Beich freebsd_committer 2021-07-28 05:46:49 UTC
Ignore comment 1. I can't remove it due to bug 191677.
Comment 3 Emmanuel Vadot freebsd_committer 2021-07-28 07:55:07 UTC
I can confirm that too.
I don't really know why though, prefer-iris is default to true now and I see -DPREFER_IRIS passed when compiling loader.c/pci_id_driver_map.c too.
So if you have any idea I'd appriciate it, otherwise I'll need to take time to look more closely later this week.
Comment 4 Jan Beich freebsd_committer 2021-07-28 10:47:07 UTC
files/patch-src_loader_meson.build added by ports 450f410688e7 is missing.
Comment 5 commit-hook freebsd_committer 2021-08-04 10:24:01 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=a751a7f865e6616b74206c3f6dad0a3c957edeec

commit a751a7f865e6616b74206c3f6dad0a3c957edeec
Author:     Emmanuel Vadot <manu@FreeBSD.org>
AuthorDate: 2021-08-03 09:13:00 +0000
Commit:     Emmanuel Vadot <manu@FreeBSD.org>
CommitDate: 2021-08-04 10:23:10 +0000

    graphics/mesa-libs: Add back patch for iris

    Due to how the mesa ports are split we need to patch meson files so
    iris is prefered on compatible intel GPU.

    PR:  257462

 graphics/mesa-dri/files/patch-src_loader_meson.build (new) | 11 +++++++++++
 graphics/mesa-libs/Makefile                                |  1 +
 2 files changed, 12 insertions(+)